Help on troubleshooting gpu and network

I have a acer travelmate p259-g2-mg with i5-7200u and nvidia 940mx gpu.
This has 2 gpu and i cannot seem to utilise even a percentage of dedicated nvidia gpu(according to nvtop).
I tried on csgo with dri_prime command, that also didn’t helped. MATLAB program reverts to software opengl beacuse it cannot find the gpu. Tried installing both open source and closed source drivers from mhwd one at a time, that also didn’t worked.

The default task manager on XFCE shows cpu and ram usage, but is there a way to monitor gpu, disk and network usage also? Always having around 1mbps usage when connecting to network is a pain on limited data connection.
You can consider me as an absolute noob!.

can you report

inxi -Fza

There you go

> [shaqib@ShaqibPC ~]$ inxi -Fza
> System:    Kernel: 5.10.30-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
>            parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
>            root=UUID=52431036-b9e7-4097-9c3c-f7c83f0344d3 rw quiet apparmor=1 security=apparmor 
>            udev.log_priority=3 
>            Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 dm: LightDM 1.30.0 
>            Distro: Manjaro Linux base: Arch Linux 
> Machine:   Type: Laptop System: Acer product: TravelMate P259-G2-MG v: V1.51 serial: <filter> 
>            Mobo: Acer model: Lyra_SK v: V1.51 serial: <filter> UEFI: Insyde v: 1.51 date: 05/31/2019 
> Battery:   ID-1: BAT1 charge: 12.3 Wh (47.1%) condition: 26.1/42.0 Wh (62.2%) volts: 14.6 min: 15.0 
>            model: SIMPLO AS16A7K type: Li-ion serial: <filter> status: Discharging 
> CPU:       Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake 
>            note: check family: 6 model-id: 8E (142) stepping: 9 microcode: DE cache: L2: 3 MiB 
>            flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21599 
>            Speed: 738 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 738 2: 708 3: 722 4: 780 
>            Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
>            Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
>            Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
>            Type: meltdown mitigation: PTI 
>            Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
>            Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
>            Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
>            conditional, RSB filling 
>            Type: srbds mitigation: Microcode 
>            Type: tsx_async_abort status: Not affected 
> Graphics:  Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel 
>            bus-ID: 00:02.0 chip-ID: 8086:5916 class-ID: 0300 
>            Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Acer Incorporated ALI driver: nvidia 
>            v: 460.67 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:134d class-ID: 0302 
>            Device-3: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 1-7:4 chip-ID: 04f2:b571 
>            class-ID: 0e02 
>            Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting,nvidia 
>            alternate: fbdev,intel,nouveau,nv,vesa display-ID: :0.0 screens: 1 
>            Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
>            Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6") 
>            diag: 394mm (15.5") 
>            OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.0.2 direct render: Yes 
> Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
>            driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 
>            class-ID: 0403 
>            Sound Server-1: ALSA v: k5.10.30-1-MANJARO running: yes 
>            Sound Server-2: JACK v: 0.125.0 running: no 
>            Sound Server-3: PulseAudio v: 14.2 running: yes 
>            Sound Server-4: PipeWire v: 0.3.25 running: no 
> Network:   Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: 4000 bus-ID: 03:00.0 
>            chip-ID: 8086:095a class-ID: 0280 
>            IF: wlp3s0 state: up mac: <filter> 
>            Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
>            vendor: Acer Incorporated ALI driver: r8168 v: 8.048.03-NAPI modules: r8169 port: 3000 
>            bus-ID: 04:00.1 chip-ID: 10ec:8168 class-ID: 0200 
>            IF: enp4s0f1 state: down mac: <filter> 
> Drives:    Local Storage: total: 931.51 GiB used: 38.88 GiB (4.2%) 
>            SMART Message: Required tool smartctl not installed. Check --recommends 
>            ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB block-size: 
>            physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 5J 
>            scheme: GPT 
> Partition: ID-1: / raw-size: 77.13 GiB size: 75.66 GiB (98.11%) used: 38.88 GiB (51.4%) fs: ext4 
>            dev: /dev/sda10 maj-min: 8:10 
>            ID-2: /boot/efi raw-size: 62 MiB size: 61.9 MiB (99.78%) used: 27.1 MiB (43.8%) fs: vfat 
>            dev: /dev/sda1 maj-min: 8:1 
> Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
>            ID-1: swap-1 type: file size: 8 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile 
> Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A 
>            Fan Speeds (RPM): N/A 
> Info:      Processes: 194 Uptime: 3m wakeups: 1 Memory: 7.64 GiB used: 1.74 GiB (22.7%) Init: systemd 
>            v: 247 tool: systemctl Compilers: gcc: 10.2.0 Packages: pacman: 1238 lib: 338 flatpak: 0 
>            Shell: Bash v: 5.1.0 running-in: xfce4-terminal inxi: 3.3.04 
> [shaqib@ShaqibPC ~]$

** To test the r8168 driver:

sudo modprobe -r r8168 && sleep 3 && sudo modprobe r8168 && systemctl restart NetworkManager

** to test GPU
by intel


by nvidia

prime-run glxspheres64
DRI_PRIME=1 glxspheres64

The command ran, but has given no output.
Network is working fine, i just want to know the realtime usage monitor for network, like there is for cpu and ram in task manager.

glxspheres64 command not found.
Prime-run command works on csgo, i am not able to get it working for MATLAB.