Help on installing nginx-rtmp

I am trying to build a streaming server on my pinebookpro. But when I build the packages from AUR, Iget this:

Building nginx-rtmp…
==> ERROR: nginx-rtmp is not available for the ‘aarch64’ architecture.

Any ideas what I can do to setup a streaming server on the pbp?
Thanks in advance - Hans-Peter

In the PKGBUILD add aarch64 to this line:

arch=(‘x86_64’ ‘aarch64’)

Thanks for the help. Build started, but came to an end with

logrotate ... Passed

==> Verifying source file signatures with gpg…
nginx-1.18.0.tar.gz … FAILED (unknown public key 520A9993A1C052F8)
==> ERROR: One or more PGP signatures could not be verified!
Failed to build nginx-rtmp

You need to add the key but you can bypass that with:

makepkg -si --skippgpcheck

there is no makepkg in the build file. do I have to add this line?

Also tried to import the key - but no luck

[hp@pbp ~]$ sudo pacman-key --recv-keys 520A9993A1C052F8
gpg: keyserver receive failed: General error
==> ERROR: Remote key not fetched correctly from keyserver.
[hp@pbp ~]$ sudo pacman-key --recv-keys B0F4253373F8F6F510D42178520A9993A1C052F8
gpg: keyserver receive failed: General error
==> ERROR: Remote key not fetched correctly from keyserver.

Run this command in the same directory that the PKGBUILD is in:

makepkg -si --skippgpcheck

makepkg command builds the package and the -i will install it.

@Darksky, I think he is trying to install it from AUR instead of building it manually.

Was there a method to ignore the signature check from pamac?

Assuming you have yay installed:

yay -S nginx-rtmp --editmenu --mflags "--skipchecksums --skippgpcheck"

Then edit the arch field, as per @Darksky’s suggestions.

Incidentally, I’ve co-maintained a couple of packages with TheGoliath on AUR. He has an aarch64 system and maintains a couple of multi-arch packages. If you are able to successfully build the package with the above command then I’d advise leaving an AUR comment. He’ll probably make the package multi-arch to simplify future installation/upgrades.

Thanks for the help, but still no luck. Using the yay command, the build comes to an end with a signature related error message, no matter if I choose to import the keys or not.

:: PGP keys need importing:
-> B0F4253373F8F6F510D42178520A9993A1C052F8, required by: nginx-rtmp
==> Import? [Y/n] y
:: Importing keys with gpg…
gpg: keyserver receive failed: General error
problem importing keys

This looks pretty much the same as the output of Package Manager, which I was using before.
Maybe it is better to try to import the missing keys. First I’ll check if the missing keys are still valid. If so, I will try to import them.

Went to the project page and saw in the comments, that other users were suspecting that there is something wrong with the keys. So I tried to find out how to install from AUR manually. Which is actually very simple. So I did:

git clone
makepkg -si --skippgpcheck

and now it’s building. Hopefully this will be a success.
Many thanks to all for the help!


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.