Help Nginx error 404 Not Found

Help Please.
Manjaro v19.0.2 - Gnome
Intel atom
2Gb ram

Every time an internet connection is established the 404 Not Found error sign appears Nginx 1.23.2 - After each reboot the 404 error sign appears again

Moderator edit: image removed

which URL you try to open and which web browser you’re using. Manjaro 19.0.2 is very old system.

I have the bgh t201x tablet and the manjaro 19 is the only one that works correctly with the hardware, it has 2GB of ram, I would just like to solve the Nginx 404 Not Found error that appears when an internet connection is established.
Everything works but that error is annoying.
Firefox is browsing correctly.
If anyone can help I’d appreciate it.

What do you mean - when an internet connection is established ?

  • is it your browser?
  • is it an attempt to sync the system?

Manjaro 19?

If the system may be 32-bit - then 32-bit repo is long gone (March 2020).

Perhaps is is in fact 64-bit - it took a while to connect to the osdn storage - 18.04 xfce was the last 32-bit - provided a year or two after 32-bit was discontinued.

If it is your browser - I assume it is - change page the browser loads initially.

Simply connecting to the Internet automatically opens the nginx 404 “not found” “access point login” “nmcheck.gnome” error message. The system is 64 bits, if I restart the system the error appears again. It’s not a Firefox problem. Apparently the system is trying to connect to the address “nmcheck.gnome”

sorry for my english, i use a translator

It is just your NetworkManager checking that your Internet connection is working by trying to download (the only working page on that subdomain). Maybe your system is just a little slow getting the network up & running, which is why it occurs after booting?

Anyway, it is definitely not malware or anything to worry about. If it only occurs after booting up, and you can surf the Internet successfully after your system has had enough time to establish networking, then you need not worry about it.

That is normal - you may disable the check by creating a file


or by copying the distribution file

sudo cp /usr/lib/NetworkManager/conf.d/20-connectivity.conf /etc/NetworkManager/conf.d
1 Like

Thank you very much @linux-aarhus , it worked perfectly.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.