Help needed with error: Wine cannot find the FreeType font library

I am attempting to install League of Legends with the Leagueoflegends-git, and I am having issues with 2 errors, if someone has any knowledge on how to solve them. I can confirm I have freetype2 2.12.0-1.

Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.

and must be installed for pthread_cancel to work
wine client error:d0: write: Bad file descriptor

Computer Specs, if needed:
Kernel: 5.15.32-1-MANJARO
DE: Plasma 5.24.4
CPU: Intel i7-4790K (8) @ 4.400GHz
GPU: NVIDIA GeForce GTX 1070 Ti
GPU: Intel HD Graphics

I may give you a hint with
This is a shared library that is supposed to belong to gcc
The problem is gcc arch build doesn’t ship with this file, which is require by wine. The solution would be easy if other arch package ship with this library which is not the case. So the theorical workaround is to compile yourself gcc in a way you build, then add to your system path the location of that file.

Another dirty and not recomendable way is downloading that file from fedora repo (using a virtual machine or container solution like docker/lxc) and hope it wont be use because its very likely your app is gonna crash trying to read that. This dirty path is only mean for a quick testing.

Try to see what files where build in leagueoflegends-git, there is a high odd you already have that file but it is not on your system path

I believe that library is part of the
which is a dependency of the wine package and should therefore be present.

Both gcc-libs and lib32-gcc-libs provide that file.

Did it install wine-lol before making this statement? As wine-lol depends on both of these.

It’s odd, I have ~65 instances of on my pc, a few of which I’ve confirmed are in /usr/lib/, I’m unaware if I need one in a different directory. I also have a windows partition, which is where a lot of the’s are coming from.

I’ve got the same problem:

Wine cannot find the FreeType font library. To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.

(but I don’t have the other error about “libgcc”.)
I’ve tried to install “freetype2” and “lib32-freetype2” but the same error appears.

My version of Freetype:

sudo pacman -Qs freetype
local/freetype2 2.12.1-1
Font rasterization library
local/lib32-freetype2 2.12.1-1
Font rasterization library (32-bit)
local/libxft 2.3.4-1
FreeType-based font drawing library for X

I think my issue at the time was that I didn’t correctly download wine-lol. I was confused, and I think I just made an edit within normal wine, and I thought that was wine-lol. I suggest starting from scratch, as much as you can, and following these steps:
Download wine-lol via terminal or your software store. I download it using terminal:
sudo pacman -S yay
yay -S wine-lol
If you’re trying to download leagueoflegends-git like me, also run this:
yay -S winetricks lib32-unixodbc
Then install leagueoflegends-git
yay -S leagueoflegends-git