Help needed to adjust to using Wayland

manjaro kde plasma: laptop with hdmi monitor as extended mode.
I was posting previously that xrandr has some bug that does not work (–primary option). My “taskbar panel” sometime jumped to the wrong monitor. I was using this cmdline to set up the monitor configuration. but the --primary option is as good as NONE. I have to use gui to overcome the issue, which is very unlinux like.

xrandr --output eDP-1 --mode 1920x1080 --pos 0x0 --rotate normal --primary --below HDMI-A-1 --output HDMI-A-1 --mode 1920x1080 --pos 0x-1080 --above eDP-1 --rotate normal --rate 60

Then i was recommended using wayland… Now i switch to wayland from x11… then i was told xrandr is not for wayland… i need to use $kscreen-doctor (which is new thing to me).

  1. after shift to wayland , now i need to learn to use kscreen-doctor to perform xrandr cmd that i need.
  2. after i shift to wayland, i found out my clipgrab app does not able to pickup video url in clipboard anymore… (in x11, i just copy any web video url into clipboard, clipgrab will detect the present of the video url and i can just download the video using it, now no longer works)
  3. after i shift to vim, i realized my "+y and "*y no longer work… i can’t copy text from within vim to outside app via clipboard.

can someone help me ? too much at once.

search engine told me got this wlr-randr is for wayland too… but when i execute it…:

$ inxi -Gxx | grep compositor
compositor: kwin_wayland driver: X: loaded: modesetting dri: crocus

$ wlr-randr
compositor doesn’t support wlr-output-management-unstable-v1
**i have no idea what is it for. **

all these switching is really killing my time…

is there way to NOT close this thread automatically if no reply within 36 hrs ?
sometime it takes me time to come back to this forum and before i realized… it is closed… and my problem is not solve yet…

After read found it really has problem with clipboard… That’s too much for me to overcome and impossible. I give up on wayland go back to x11…
Not the time to use wayland, too “in progress”.

You don’t need any command line to setup your monitors on Wayland, simply use Plasma GUI to do it.

First grab your monitor by mouse in Plasma settings to position it under your laptop screen, and set its resolution, orientation and refresh rate.

Then select your built-in screen and set it to primary, and also set its resolution, orientation and refresh rate.

ClipGrab 3.9.10 is able to grab copied URL automatically without any issue on Plasma 6.0.4/Wayland


I beg to differ. I simply do not recognise the problems I am reading about.

It is important to realise the following

  • Nvidia proprietary drivers is not good with Wayland - that is Nvidia’s issue
  • If you are using dual-gpu system with Nvidia - stay with Xorg - still not a Wayland issue
  • You cannot expect a smooth transition Xorg → Wayland
  • If you are relying in xorg utilities to create your monitor layout you need to use other tools
  • If you are using xorg utilities to grab textual input you will have to switch to wayland tools

These changes does not imply that Wayland is not usable.

  • copy/paste → wl-clipboard
  • screen layout → use display setup in settingsmanager as @medmedin shows

Fun Fact

  • I have been using Wayland for quite a while now - 6.0 since the first beta last year - and a long time before that - so long I don’t even remember.
  • I actually switched to Wayland so I would know what I am talking about when users complain about Wayland.

I had several issues when switching from a working X installation to Wayland too. But after a reinstallation, which I had to do anyway, Wayland is running fine. There are some minor issues, but overall it’s good.
I guess there’s a major misconfiguration at your end causing all these problems. Or better said: some things need to be reconfigured to work properly.

For 3: you do have gvim installed, right?

Edit:- Changed thread Title to something more relevant and search friendly.

Thx for the efford.

  1. I know the gui method. However I want cmdline method to arrange my screen. (i move laptop from place to place, always with extend hdmi monitor. When i move back home extended monitor, the configuration often messed up. I dislike gui method, prefer cmdline… 1 cmdline fix the whole display configuration error is what i want. Not like the idea of doing that using gui method.
  2. My $clipgrab -v
    ClipGrab 3.9.10
    however it does not grab url from clipboard. i tried twice on wayland. when switched to x11, it works just fine.
  3. " Nvidia proprietary drivers is not good with Wayland - that is Nvidia’s issue" . Since you don’t have this issue, then must be the wayland-Nvidia issue. Sadly i am on Nvidia laptop, i can’t change that fact and i still need the system to be working.

Ya, i regret my laptop is Nvidia… a lot of headache using linux… but i don’t have budget for a new laptop.
Thanks for helping ppl using linux…

ya. I am using gvim. i have no idea (have not find soln that works on my laptop yet) what can i do to fix the issue. it runs fine on x11.

The hurdle for me to switch is too many problem i encounter at once, i can’t work with all those 3 issues. I rather have 1 issue (screen configuration issue on dual monitor when using xrandr cmdline) then 3 issues all at once.

Thanks for helping.

ya Gvim.

The many member with Nvidia powered laptops - coupled with the fact that Plasma and Gnome defaults to Wayland - are the main reason why a testing snap to stable has been delayed.

A tremendous amout of work is being put into making the transitions as smooth as possible.

No one on the team expects it to be a walk in the park but a lot of work is done to remove the most obvious obstacles.

I know and appreciate the effort put in for all open source project… no doubt.
However i have only this laptop .