Help needed: Cannot install displaylink drivers

Hey there!
Running latest Manjaro version on a Lenovo Legion 5 Gaming Laptop. I also have a ThinkPad USB 3.0 Dock that has 2x DVI ports, usb ports, etc.

The problem is that after running commands pamac build displaylink and evdi I get this message when running systemctl status displaylink.service:

× displaylink.service
     Loaded: not-found (Reason: Unit displaylink.service not found.)
     Active: failed (Result: exit-code) since Sun 2022-10-23 02:23:25 EEST; 5min ago
        CPU: 2ms

Oct 23 02:23:25 main systemd[1]: displaylink.service: Failed to schedule restart job: Unit displaylink.service not found.
Oct 23 02:23:25 main systemd[1]: displaylink.service: Failed with result 'exit-code'.

journalctl -xeu displaylink.service returns this:

Oct 23 02:23:22 main systemd[1]: Starting DisplayLink Manager Service...
░░ Subject: A start job for unit displaylink.service has begun execution
░░ Defined-By: systemd
░░ Support:
░░ A start job for unit displaylink.service has begun execution.
░░ The job identifier is 11587.
Oct 23 02:23:22 main modprobe[3274]: modprobe: FATAL: Module evdi not found in directory /lib/modules/5.15.74-3-MANJARO
Oct 23 02:23:22 main systemd[1]: displaylink.service: Control process exited, code=exited, status=1/FAILURE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support:
░░ An ExecStartPre= process belonging to unit displaylink.service has exited.
░░ The process' exit code is 'exited' and its exit status is 1.
Oct 23 02:23:22 main systemd[1]: displaylink.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support:
░░ The unit displaylink.service has entered the 'failed' state with result 'exit-code'.
Oct 23 02:23:22 main systemd[1]: Failed to start DisplayLink Manager Service.

How can I get my 3rd display connected to the dock via DVI to work? PS. I am a total beginner

What is your objective?

You have 3 displays.
You have a dock.

I guess you want the laptop display, as well as two others connected to the dock to work?

This seems to be the actual question, not reflected in the title.

The displaylink.service … might not be the proper way to achieve what you want.

But I have no idea.

I just noticed that your attempted way to solve your problem
installing displaylink.service
(from AUR, which is technically unsupported)
might not even be the right approach to get there

xy problem?

Looks like evdi is not installed… tried a reboot? Possible that you didn’t reboot after a kernel upgrade.

or probe it manually:

sudo modprobe -v evdi

I am not sure because this is a fresh install. I installed it yesterday.

Running sudo modprobe -v evdi returns this:
modprobe: FATAL: Module evdi not found in directory /lib/modules/5.15.74-3-MANJARO

How can I get the module evdi to /lib/modules/5.15.74-3-MANJARO

Objective is to get the 3rd display to work properly. The Dock uses displaylink technology.

"Install evdi (AUR) or evdi-git (AUR) for the in development kernel module.
Install the displaylinkAUR driver. For Xorg it allows configuring DisplayLink monitors using Xrandr in the same manner as the udl driver; for Wayland no configuration is necessary.
Enable displaylink.service.
For Xorg use the "modesetting" driver with AccelMethod "none" and MatchDriver "evdi". "

I have done this:

  1. pamac build displaylink (it automatically built evdi)
  2. created the file /etc/X11/xorg.conf.d/20-evdi.conf and wrote
    Section “OutputClass”
    Identifier “DisplayLink”
    MatchDriver “evdi”
    Driver “modesetting”
    Option “AccelMethod” “none”
  3. Reboot

sudo systemctl enable displaylink

Failed to enable unit: Unit file displaylink.service does not exist.


How can I enable the displaylink.service?
It fails to start because evdi is missing from /lib/modules/

" Load the framebuffer device

Before your system will recognize your DisplayLink device, the udl kernel module must be loaded. To do this, run

modprobe udl

If your DisplayLink device is connected, it should show some visual indication of this. Although a green screen is the standard indicator of this, other variations have been spotted and are perfectly normal. Most importantly, the output of dmesg should show something like the following, indicating a new DisplayLink device was found: "

again, if you’re not willing to read the manual do not expect that others will do it for you.

i’m out

[ 2759.865392] usb 6-2.4.1: new SuperSpeed USB device number 10 using xhci_hcd
[ 2759.882700] usb 6-2.4.1: New USB device found, idVendor=17e9, idProduct=4302, bcdDevice=30.14
[ 2759.882710] usb 6-2.4.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2759.882714] usb 6-2.4.1: Product: ThinkPad USB 3.0 Dock
[ 2759.882717] usb 6-2.4.1: Manufacturer: DisplayLink
[ 2759.882719] usb 6-2.4.1: SerialNumber: 10844423

after that there is NOT a

[drm] Initialized udl 0.0.1 20120220 on minor 1

It seems that udl is not initializing

no comment

I could not find how to initialize it.

sudo modprobe udl

does not work!

I have my Thinkpad Laptop (No nvidia GPU) and a Thinkpad USB3.0 Dock that connects to dual monitors via two HDMI cables without any issue.

I do not need to use displaylink driver. I have no idea why do you need it?

Check if it is avaible in the kernel

$ sudo modinfo udl

If the module udl not found, try to switch to the kernel 5.19 .

In Windows 10 the device worked plug n play. No need to install any drivers.

On Manjaro (prev. Fedora 36) everything except the displays work.

sudo modinfo udl

returns this

filename: /lib/modules/5.15.74-3-MANJARO/kernel/drivers/gpu/drm/udl/udl.ko.xz
license: GPL
srcversion: FB9A98C4B7F7EB533A6A7D0
alias: usb:v17E9pddcdscdpicFFisc00ip00in
retpoline: Y
intree: Y
name: udl
vermagic: 5.15.74-3-MANJARO SMP preempt mod_unload
sig_id: PKCS#7
signer: Build time autogenerated kernel key
sig_key: 17:BE:1B:C2:EF:A3:73:04:41:44:A4:1C:D0:EC:C9:7B:F0:6E:CC:29
sig_hashalgo: sha512
signature: 30:64:02:30:70:80:6C:C8:29:17:BF:B3:D0:0D:DE:B6:E0:60:37:AB:

uname -r



uname -r => 5.19.16-2-MANJARO

● displaylink.service - DisplayLink Manager Service
Loaded: loaded (/usr/lib/systemd/system/displaylink.service; enabled; preset: disabled)
Active: active (running) since Mon 2022-10-24 16:00:55 EEST; 5min ago
Process: 626 ExecStartPre=/sbin/modprobe evdi (code=exited, status=0/SUCCESS)
Main PID: 631 (DisplayLinkMana)
Tasks: 28 (limit: 19021)
Memory: 29.3M
CPU: 1.117s
CGroup: /system.slice/displaylink.service
└─631 /usr/lib/displaylink/DisplayLinkManager
Oct 24 16:00:55 main systemd[1]: Starting DisplayLink Manager Service…
Oct 24 16:00:55 main systemd[1]: Started DisplayLink Manager Service.

Reinstalled dislaylink and nvidia drivers. The monitor is still black.

sudo dmesg | grep drm

[ 0.728669] ACPI: bus type drm_connector registered
[ 1.721665] systemd[1]: Starting Load Kernel Module drm…
[ 1.726053] systemd[1]: modprobe@drm.service: Deactivated successfully.
[ 1.726155] systemd[1]: Finished Load Kernel Module drm.
[ 3.498318] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[ 3.498320] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 0
[ 4.760480] evdi evdi.0: [drm] Cannot find any crtc or sizes
[ 4.760717] [drm] Initialized evdi 1.12.0 20220713 for evdi.0 on minor 1

But still xrandr --listproviders is

Providers: number : 1
Provider 0: id: 0x1b7 cap: 0x1, Source Output crtcs: 4 outputs: 4 associated providers: 0 name:NVIDIA-0


For anyone wondering I did this:

and blacklisted udl and udlfb

Thank you all for helping and for the patience!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.