Help, I broke my Manjaro[SOLVED]

Which DE did you install first?

Manjaro Xfce

If you can use startx and everything is OK, you probably have problem with lightdm. First thing is to check if running (probably not) and what’s the error with:
systemctl status lightdm

Easy solution: startx, open pamac-manager, reinstall lightdm & lightdm-gtk-greeter, after that check if your current lightdm configuration differs from default:
`sudo find /etc/lightdm/ -name ‘*pac*’

If you haven’t differences then logout and at terminal execute:
sudo systemctl restart lightdm
and you are ready

If you find new *.pacnew or *.pacsave files then open with for example:
sudo meld /etc/lightdm/lightdm.conf /etc/lightdm/lightdm.conf.pacnew
and correct from right to the left, after that do the previous step. (logout,restart lightdm)

If you have network problems (are u using different pc | mobile to post here?) post output of commands:
systemctl status NetworkManager
systemctl restart NetworkManager
wifi on
ping -c2


It’s fixed now, I did a fresh install of minimal Xfce Manjaro, thanks everyone.


1 Like

Pease, mark it as solved

Not my post, the post you think it would be the answer to you ask so anyone how search for your question would found the right answer