Help, I broke my Manjaro[SOLVED]


I’ve been using Manjaro XFCE for about 4 months now, all good with that. Yesterday I decided to check Gnome out(because it has some extensions that allow you to configure the power management of the laptop in an easier way) so after trying it out for a few hours and realizing that I love XFCE, I tried to uninstall Gnome, and thats where my problems come from, after removing Gnome I’m not able to go back to the normal GUI like I always did, when I boot i get prompted to the CLI tty stuff, I can go back to my GUI after typing “startx” but I want things to be the way they were before, where I would boot straight into my login GUI interface and handle things from there. Thanks a lot to anyone that helps me. First post.

Hello Pablo and welcome to the Manjaro forums!

Maybe you have something else, but I think the first thing to try is to set the default boot target:

sudo systemctl set-default

Let’s see what happens


Ok, just tried that, after doing “reboot” after it goes back to the same CLI

Besides the login problem, I’d tell you that you don’t need to install other DE just to try a better power manager for laptops, There’re some apps to do so. You have tlp and tlpui, slimbookbaterry, and others. Tlp come by default in manjaro instalations, it comes with a default config.Tlp is a cli application, it’s for terminal use, but you can install tlpui, that’s a frontend gui, much easier to configure.
Personally I use slimbookbattery, it use tlp but it has a gui inteface so easy to configure.
Been said all that, if you want to install other DE, it’s up to you, I’m just saying there other options


Ok. Then you have some else and we have to find it. Run

sudo journalctl -b

and try to find some error that tells you why is not booting in graphical mode.

If you don’t find it, you cant upload the logs with:

sudo journalctl -b | curl -T -

and post here the link to try to help you.

“Sudo: systemct : command not found”

I get this after trying systemct.


Sorry, my bad. Typo there. Correct one is

sudo journalctl -b

I’ll correct the original post

" systemctl: invalid option – ‘b’ "



Ok. Clearly it’s not my day. It’s not systemctl, it’s journalctl !!! Sorry!

sudo journalctl -b

Its okay, its my first time posting as well, I’ll try to keep up!

I did “sudo journalctl -b” and I got a very long list, doing

sudo journalctl -b | curl -T - https : //a ptge /jou rnal.txt I get "curl: (6) Could not resolve host:


sudo journalctl -b | curl -T -ht tps :confused: /aptg et.x yz/jo urnal.txt I get

"Warning: The file name argument ‘-https :confused: /apt /journal.txt’ looks like a warning flag.
curl: no URL specified!
curl: try ‘curl --help’ for more information

(I cant include links in my post thats why I used spaces)

I think you are running it in text mode, but it seems that you don’t have network connectivity until you start the graphical mode. You can run the command from a console window in your DE.

looks like a typo. it is “” and not “”

there is supposed to be a space between the hyphen and the “https”

If this is the case you can ping google and check (or any other ip you know is online and accessible) with


No I dont have network connectivity now, my router is up and running so it’s on my laptop’s end.


Do you not have network connectivity even after entering your DE?

Just a question. Why did you uninstall Gnome before installing Xfce?

Maybe I should just clean install Manjaro? All my files are saved I wouldnt be losing much except for a few apps that I can reinstall.


1 Like

Probably the easiest solution


A clean installation is, of course, a good method if you have a backup.

1 Like

Yes. I did “startx” but the usual network icon in the tray is no longer there

I installed Xfce but I think my issue comes from when I uninstalled Gnome it took away a lot of things that Xfce was using as well and now I’m missing important files(my wifi is not working on my laptop now)

1 Like