Help for getting write caching disabled on nvme sdd

I have a WD blue drive and it is extremely slow with write caching on turning it off in windows fixed the issue but I cannot find a way to disable write caching on manjaro.
Help is appreciated :pray:

Why and how would a drive “get faster” by turning off that feature?

post info on the drive, on the system
inxi …

What is the perceived problem?


Hace you tried mounting the drive in /etc/fstab with the “sync” option?

wouldn’t that be like issuing “sync” very often?
to force writing data to disk
effectively increasing writes and therefore decreasing the life-cycle?

That is what I’d think, what is my intuition, based upon man mount.

1 Like

More or less. This is the same as adding a sync order each time the computer needs writing some data in the disk and each writing order is performed once the previous order has finished. In a HDD means I/O is muuuuch slower, but i haven’t tested it in a SSD.

You might also look at TRIM settings for your NVMe.
Some useful links for research:



Also be sure you have installed the latest firmware available for your drive:

Some WD blue drives had reliability problems solved with new firmwares.

Assuming updates is available using

The following may help - no responsiblity or warranty assumed

sudo pacman -Syu fwupd
fwupdmgr refresh
fwupdmgr get-updates
fwupdmgr update

You probably want to include fwupdmgr refresh in there before the update.
It refreshes the metadata from the server.
get-updates gets the list of updates for connected hardware.

1 Like