Help fixing gnome boxes

I decided to play around with gnome boxes today to see if I could make a vm on an external hard drive. I use gnome boxes to download a live session of Ubuntu 20.10. After that, I found the vm in my .local file and cut and pasted it into my external hdd, then I ran the command

ln -s /run/media/justinb/My Passport/Virtual Machines ~/.local/share/gnome-boxes/images/

Now every time I startup gnome boxes it will open up for a second and then immediately close after that. I’ve tried to unlink the location and reinstalling gnome boxes but neither option has yielded any results. Honestly I’m not really sure what to do about this since all I did was make a symbolic link. Does anyone have any ideas how I can troubleshoot this?

Did you really run the command like that, without quotes and without escaping the spaces?

Moving the files may not be enough.

In most virtual vm managers contain an option to add or import a VM - use that functionality to open the vm from the new location - maybe remove it from the system config before this action.

true but from my understanding gnome boxes doesn’t have this option. and this was the answer I git when researching it online.

yes and it ran (as far as I could tell) but maybe that’s the issue?

It might be. If you do not quote filenames with spaces in them or escape the spaces with a backslash (""), then those spaces are interpreted as separators, meaning that the word after the space is considered a separate filename. As such, you probably have some broken symlinks lingering around.

Hmmm is there an easy way to clear out broken sysmlinks?

Just check your home directory for anything named…

  • Passport
  • Passport/Virtual
  • Machines

The above of course assuming that you were in your home directory when you issued the command.

1 Like

okay after some more research I found the solution. all I had to do was find where I pasted the virtual machine and put it back under .local. Honestly still not sure why gnome boxes would break because of this but now I know ¯_( ツ)_/¯

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.