Help building cuda-9.0 (again)

Hello all. I successfully compiled this on this same machine 2 weeks ago, but got a different hard drive and I’m having this trouble for days now. Here’s my inxi:

[user@ltp ~]$ sudo inxi -Fmxxxz
[sudo] password for user: 
System:    Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 
           info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 20AN009CUS v: ThinkPad T440p serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: LENOVO model: 20AN009CUS v: 0B98401 PRO serial: <filter> UEFI: LENOVO v: GLETA1WW (2.55 ) date: 04/20/2020 
Battery:   ID-1: BAT0 charge: 50.2 Wh (100.0%) condition: 50.2/56.2 Wh (89.4%) volts: 12.3 min: 10.8 model: LGC 45N1147 
           type: Li-ion serial: <filter> status: Full 
Memory:    RAM: total: 15.52 GiB used: 1.96 GiB (12.6%) 
           Array-1: capacity: 16 GiB slots: 2 EC: None max-module-size: 8 GiB note: est. 
           Device-1: ChannelA-DIMM0 size: 8 GiB speed: 1600 MT/s type: DDR3 detail: synchronous bus-width: 64 bits 
           total: 64 bits manufacturer: 1324 part-no: H641GU67G1600G serial: N/A 
           Device-2: ChannelB-DIMM0 size: 8 GiB speed: 1600 MT/s type: DDR3 detail: synchronous bus-width: 64 bits 
           total: 64 bits manufacturer: 0000 part-no: N/A serial: N/A 
CPU:       Info: Quad Core model: Intel Core i7-4700MQ bits: 64 type: MT MCP arch: Haswell rev: 3 cache: L1: 64 KiB L2: 6 MiB 
           L3: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38321 
           Speed: 2395 MHz min/max: 800/3400 MHz volts: 0.8 V ext-clock: 100 MHz Core speeds (MHz): 1: 2395 2: 2395 3: 2394 
           4: 2395 5: 2394 6: 2395 7: 2394 8: 2398 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:0416 class-ID: 0300 
           Device-2: NVIDIA GK208M [GeForce GT 730M] vendor: Lenovo driver: nvidia v: 460.56 bus-ID: 02:00.0 
           chip-ID: 10de:1290 class-ID: 0300 
           Device-3: Acer SunplusIT Integrated Camera type: USB driver: uvcvideo bus-ID: 2-12:4 chip-ID: 5986:0268 
           class-ID: 0e02 
           Display: server: X.Org 1.20.10 driver: loaded: modesetting resolution: 1920x1080~60Hz s-dpi: 96 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) v: 4.5 Mesa 20.3.4 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Lenovo ThinkPad T440p driver: snd_hda_intel 
           v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c class-ID: 0403 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo ThinkPad T440p driver: snd_hda_intel 
           v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20 class-ID: 0403 
           Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.23 running: no 
Network:   Device-1: Intel Ethernet I217-LM vendor: Lenovo ThinkPad T440p driver: e1000e v: kernel port: 4080 bus-ID: 00:19.0 
           chip-ID: 8086:153a class-ID: 0200 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel port: 3000 bus-ID: 04:00.0 chip-ID: 8086:08b2 
           class-ID: 0280 
           IF: wlp4s0 state: up mac: <filter> 
Drives:    Local Storage: total: 523.38 GiB used: 147.38 GiB (28.2%) 
           ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: YAM1 scheme: GPT 
           ID-2: /dev/sdb type: USB model: General USB Flash Disk size: 57.62 GiB rotation: SSD serial: <filter> rev: 1100 
           scheme: GPT 
Partition: ID-1: / size: 31.25 GiB used: 16.43 GiB (52.6%) fs: ext4 dev: /dev/sda2 
           ID-2: /boot/efi size: 98.4 MiB used: 298 KiB (0.3%) fs: vfat dev: /dev/sda1 
           ID-3: /home size: 410.11 GiB used: 82.83 GiB (20.2%) fs: ext4 dev: /dev/sda4 
Swap:      ID-1: swap-1 type: partition size: 16 GiB used: 2 MiB (0.0%) priority: -2 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 56.0 C mobo: 0.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 244 Uptime: 10h 15m wakeups: 1 Init: systemd v: 247 Compilers: gcc: 10.2.0 alt: 6 Packages: pacman: 1203 
           Shell: Bash (sudo) v: 5.1.0 running-in: terminator inxi: 3.3.03

I’ve tried repeatedly with yay, pamac and pamac gui and all end with the same error.

libtool: install: (cd /home/user/.cache/yay/gcc6/pkg/gcc6/usr/lib/gcc/x86_64-pc-linux-gnu/6.5.0/plugin && { ln -s -f || { rm -f && ln -s; }; })
libtool: install: /usr/bin/install -c .libs/libcc1plugin.lai /home/user/.cache/yay/gcc6/pkg/gcc6/usr/lib/gcc/x86_64-pc-linux-gnu/6.5.0/plugin/
libtool: install: warning: remember to run `libtool --finish /usr/lib/gcc/x86_64-pc-linux-gnu/6.5.0/plugin'
libtool: install: /usr/bin/install -c .libs/ /home/user/.cache/yay/gcc6/pkg/gcc6/usr/lib/../lib/
libtool: install: (cd /home/user/.cache/yay/gcc6/pkg/gcc6/usr/lib/../lib && { ln -s -f || { rm -f && ln -s; }; })
libtool: install: (cd /home/user/.cache/yay/gcc6/pkg/gcc6/usr/lib/../lib && { ln -s -f || { rm -f && ln -s; }; })
libtool: install: /usr/bin/install -c .libs/libcc1.lai /home/user/.cache/yay/gcc6/pkg/gcc6/usr/lib/../lib/
libtool: install: warning: remember to run `libtool --finish /usr/lib/../lib'
make[3]: Leaving directory '/home/user/.cache/yay/gcc6/src/gcc-build/libcc1'
make[2]: Leaving directory '/home/user/.cache/yay/gcc6/src/gcc-build/libcc1'
make[1]: Leaving directory '/home/user/.cache/yay/gcc6/src/gcc-build/libcc1'
rm: cannot remove '/home/user/.cache/yay/gcc6/pkg/gcc6//usr/lib/gcc/x86_64-pc-linux-gnu/6.5.0/*': No such file or directory
==> ERROR: A failure occurred in package_gcc6().
error making: gcc6 (gcc6-libs)

I decided to try to build gcc6 seperately and got it done with a clean build:

[user@ltp ~]$ pacman -Q gcc6
gcc6-multilib 6.5.0-1

but when I try to build cuda-9.0 it chooses to rebuild gcc6 and fails even though I already have it built. The gcc6-multilib is what I used last time and it built and worked. It’s not giving the option to edit the pkgbuild, but I’ve never done that before anyway.

Does anyone know how I can get through this? It’s been days and all suggestions are welcome.

Edit: I just realized I put that drive in my MSI which needs the current cuda, but it still has the 9.0 right now. I wonder, if I format a flash drive ext4, if I can copy it over to the thinkpad…

[user@laptop .work]$ pacman -Q cuda-9.0
[user@laptop .work]$ sudo find / -name cuda-9.0
[sudo] password for user: 
find: ‘/run/user/1000/gvfs’: Permission denied
[user@laptop .work]$

Pinned post from gcc6 webpage AUR (en) - gcc6

I highly recommend building this package in a clean chroot. This avoids the use of a AUR helper, which sometimes uses /tmp as the stating directory, which often gets filled completely by gcc’s build process.

It also provides a clean environment, which minimizes interactions between your current environment and gcc’s build process.

1 Like

Just finished to build gcc6 with buildpkg, no problems

1 Like

Yes, I built gcc6 too.

[user@ltp ~]$ pacman -Q gcc6
gcc6-multilib 6.5.0-1

It’s when I try to build cuda-9.0 and it insists on RE-building gcc6 that I get the issue. You say you built it with buildpkg. You didn’t use an AUR helper?

Thanks. I saw that too. I have no idea how to build from AUR without an AUR helper. This is the first I’ve heard of it. And when they say to build in a clean chroot, do they mean like to boot a USB installer and chroot into my install and build there? Thank you for the response.

I just figured out that when yay asks, “Diffs to show?” it gives a chance to edit the build. I was thinking of removing the part where it builds gcc6, but I haven’t had time to look through it yet. Would this be a good idea?

cuda-9.0 explicity depends and gcc6 and gcc6-libs while you have gcc6-multilib installed

There is a program that create a temporary chroot to build the pacakge

I am using buildpkg from manjaro-tools-pkg but I have been told yesterday that is deprecated in favour of chrootbuild (from manjaro-chrootbuild)

Using git and makepkg/buildpkg (and create an AUR account for getting notifications) is enough for long terms AUR maintainance, might not be convenient for most

Yeah, you could remove it if you’re not going to build stuff I guess

yay gives the option of gcc6 or gcc6-multilib when building cuda-9.0. I chose the multilib and it worked to finish the build and hashcat worked as well. That cuda 9.0 is in another hard drive in another laptop. I formatted a flash drive ext4 and copied /usr/share/licenses/cuda-9.0 and /opt/cuda-9.0 to my current drive and hashcat is working now, but pacman doesn’t know cuda-9.0 is installed.

[user@ltp ~]$ pacman -Q cuda-9.0
error: package 'cuda-9.0' was not found

[user@ltp .work]$ hashcat --hash-type 2500 --opencl-device-type 2 sophia.hccapx rockyou.txt
hashcat (v6.1.1) starting...

* Device #1: CUDA SDK Toolkit installation NOT detected.
             CUDA SDK Toolkit installation required for proper device support and utilization
             Falling back to OpenCL Runtime

* Device #1: This hardware has outdated CUDA compute capability (3.5).
             For modern OpenCL performance, upgrade to hardware that supports
             CUDA compute capability version 5.0 (Maxwell) or higher.
* Device #1: WARNING! Kernel exec timeout is not disabled.
             This may cause "CL_OUT_OF_RESOURCES" or related errors.
             To disable the timeout, see:
nvmlDeviceGetCurrPcieLinkWidth(): Not Supported

nvmlDeviceGetClockInfo(): Not Supported

nvmlDeviceGetFanSpeed(): Not Supported

nvmlDeviceGetClockInfo(): Not Supported

nvmlDeviceGetTemperatureThreshold(): Not Supported

nvmlDeviceGetTemperatureThreshold(): Not Supported

nvmlDeviceGetUtilizationRates(): Not Supported

OpenCL API (OpenCL 1.2 CUDA 11.2.162) - Platform #1 [NVIDIA Corporation]
* Device #1: GeForce GT 730M, 704/983 MB (245 MB allocatable), 2MCU

Minimum password length supported by kernel: 8
Maximum password length supported by kernel: 63

Hashes: 2 digests; 1 unique digests, 1 unique salts
Bitmaps: 16 bits, 65536 entries, 0x0000ffff mask, 262144 bytes, 5/13 rotates
Rules: 1

Applicable optimizers applied:
* Zero-Byte
* Single-Hash
* Single-Salt
* Slow-Hash-SIMD-LOOP

Watchdog: Temperature abort trigger set to 90c

Host memory required for this attack: 99 MB

Dictionary cache built:
* Filename..: rockyou.txt
* Passwords.: 14344391
* Bytes.....: 139921497
* Keyspace..: 14344384
* Runtime...: 2 secs

Cracking performance lower than expected?        

* Append -w 3 to the commandline.
  This can cause your screen to lag.

* Update your backend API runtime / driver the right way:

* Create more work items to make use of your parallelization power:

[s]tatus [p]ause [b]ypass [c]heckpoint [q]uit =>

Even though it is working, I’d rather have it installed correctly.

You need to rebuild the package, I don’t know you but I caching both builded packages and sources

Sorry but I’m not sure what that means.

I’m currently trying to get my hotspot connection working so I can try to buid again over here.

I have configured a common destination for downloaded sources and builded packages in /etc/makepkg.conf

for reusing them

1 Like

Does that mean they can be installed on my machine?

I’m learning now how to build without AUR helpers and OMG I already know how to git clone, I just didn’t know you could git clone from AUR.

I don’t if or where yay is caching builded packages, about the sources it is deleting them by default as another user complained in the last days