Help a n00b out! system frozen

I need some help…my system completely froze after opening a tab in firefox… I am trying to follow the steps outlined here:

But not even terminal will open…
I have tried ctl + alt + T
And even tried dropping into tty with ctl + alt + f2/3/4
With absolutely no response.

Usually pushing the power button will bring up the “log out screen” and from there i can select cancel and the system will be fine again…but not this time.
I desperately do not want to do a hard reset because I have many projects open in gimp that I do not believe would be recoverable.

I just updated my system yesterday, running KDE plasma but I don’t know off the top of my head any version numbers. But Im on a MacBook pro if that helps

It will not work “out of the box” - it has to be enabled first.

From that post:

How to invoke the REISUB procedure?
First we have to unlock the SysRq key so:

  • Execute echo kernel.sysrq=1 | sudo tee --append /etc/sysctl.d/99-sysctl.conf

If you have not done that prior to your lockup - you can’t do it now
… if you can’t get to a TTY or a terminal …
If you can:
would make relatively sure that the inevitable fsck on reboot will not have too many problems recovering.

Thanks for your response!

Might there be any other alternatives to allow me to execute the sync command (other than ctl + alt + t for console) ?
I recall some sort of ‘search bar’ type widget that would drop down and allowed you to run commands…Although if I can’t open terminal via keyboard, it’s probably safe to say that another program isn’t going to magically open … Facepalm

Does that just leave my options at:
" Yank power cord from a laptop without battery"
“Pull circuit breaker on House / Street / Block”

No, the more “civilized” option would probably be:
press and hold the power button for a few seconds until the thing turns off. :grin:

1 Like