Headphone mic not working but showing on PulseAudio

Hi there!

I decided to try Manjaro after trying Zorin OS and not been able to correctly configure it so I’m kind noob with the OS (and also with the forum, as I’ve recently created the account.

The main problem with Zorin was audio-related issues (mainly related to the mic) and though the situation has gotten better on Manjaro I’m still facing some problems.

Built-in speakers and mic work correctly, but whenever I try to plug in headphones with integrated mic I can’t make it work. The mic it’s showing on both, PulseAudio control panel and in alsamixer but no sound is produced. Also the sound form the headphones work correctly.

I don’t have other headphones, but I’ve tried these in other laptop and it works correctly, any ideas on what may be happening? Tell me whatever logs you may need.

Many thanks!!!

Welcome to Manjaro

Please post system information:

ìnxi -Faz

and ALSA information

sudo alsa-info.sh --upload

Use 3 backticks on terminal responses to format the text
(and to avoid problems with the forum anti-spam policy of blocking hyperlinks)

hey @nikgnomic
The OS seems terrific, there’s so much I was able to customize.
I have similar issue with mic. Internal Mic works. Headphone mic doesn’t.
Please see this output

System:    Kernel: 5.11.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 root=UUID=80600993-862a-4954-bd73-8ca82f953daf ro quiet apparmor=1 
           security=apparmor resume=UUID=8b11817b-7fff-4e2f-8a74-cb9d4bcc3a8f udev.log_priority=3 
           Desktop: KDE Plasma 5.21.80 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FX505GT_FX505GT v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: FX505GT v: 1.0 serial: <filter> UEFI: American Megatrends v: FX505GT.310 date: 11/26/2020 
Battery:   ID-1: BAT0 charge: 27.5 Wh condition: 45.6/48.1 Wh (95%) volts: 11.7/11.7 model: Simplo SDI ICR18650 type: Li-ion 
           serial: <filter> status: Unknown cycles: 41 
CPU:       Info: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6 
           model-id: 9E (158) stepping: A (10) microcode: DE L2 cache: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38408 
           Speed: 4100 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 4100 2: 4055 3: 4100 4: 4100 5: 4100 6: 4051 7: 4099 
           8: 4098 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           class ID: 0300 
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK driver: nvidia v: 460.39 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f91 class ID: 0300 
           Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus ID: 1-11:3 chip ID: 13d3:56a2 
           class ID: 0e02 serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: modesetting,nvidia display ID: :0 
           screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 75 s-size: 652x366mm (25.7x14.4") s-diag: 748mm (29.4") 
           Monitor-1: eDP-1-1 res: 1920x1080 hz: 144 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5") 
           OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 460.39 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: sof-audio-pci 
           alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 class ID: 0403 
           Sound Server: ALSA v: k5.11.0-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           chip ID: 8086:a370 class ID: 0280 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: 3000 
           bus ID: 03:00.0 chip ID: 10ec:8168 class ID: 0200 
           IF: enp3s0 state: down mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8 bus ID: 1-14:4 
           chip ID: 8087:0aaa class ID: e001 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 942.7 GiB used: 56.33 GiB (6.0%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2200V MTFDHBA512TCK size: 476.94 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: P1MA0V4 temp: 32.9 C 
           scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 023 scheme: GPT 
Partition: ID-1: / raw size: 84 GiB size: 82.18 GiB (97.84%) used: 24.4 GiB (29.7%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 
           ID-2: /boot/efi raw size: 260 MiB size: 256 MiB (98.46%) used: 25.6 MiB (10.0%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw size: 100 GiB size: 97.93 GiB (97.93%) used: 31.9 GiB (32.6%) fs: ext4 dev: /dev/sda4 maj-min: 8:4 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2 maj-min: 8:2 
Sensors:   System Temperatures: cpu: 56.0 C mobo: 27.8 C gpu: nvidia temp: 51 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 298 Uptime: 15m wakeups: 1 Memory: 7.63 GiB used: 4.05 GiB (53.1%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 Packages: 1389 pacman: 1369 lib: 393 flatpak: 16 snap: 4 Shell: Zsh v: 5.8 running in: konsole 
           inxi: 3.3.01 

I’ve added some things that I’ve found online that said would solve the mic problem.

options snd-hda-intel enable_msi=1


options snd-hda-intel dmic_detect=0

I tried switching the kernels to 5.4lts, 5.9.16-1 and 5.10.15-1 as suggested in some forum.
There were some differences like audio would switch to headphones when pluggedin,
but mic still doesn’t work.

Everythings great but it’s annoying that I couldn’t get this to work.
thank you again for helping