Headphone jack not working

Hi there,
I haven an Asus Zenbook and I was trying to make its headphone jack work. Out of the box, I had normal sound output whith earphones plugged in but no microphone detected. So I started looking into this issue and played with hdajackretask to reassign the jack. Long story short, now I don’t have any sound at all, meaning I’ve lost output sound as well.

At this point, I’d like my output sound restored.
But if you can help me setup both output AND input (microphone) that would be wonderful.

Without knowing what you did, it’s hard to figure out how to reset it.

Those changes were within user or root space?

You can always create a new user, which will have system defaults. This will help you check if on this user the issue is also present or not. If not, then the issue is with user configs and your next step is to identify which ones and delete/rename them. Or if you can’t, nuke all configs by renaming .config to .config.bak, then you can slowly restore relevant configs to various apps if you need them. Of course, some configs are located elsewhere, so it may be harder to find them.

If you made changes to root space, you must recall what you did and undo those changes to the best of your abilities. If you cannot, then reinstall or restoring backup is the only way. This will teach you to either keep notices when modifying your system or doing backups, or both.

I have the same issues with a new user as well.
I know all too well I messed up, as you say, lesson learned. But is there really no way of investingating this? I guess I’ll fire up hdajackretask again and try different settings. Nothing to lose at this point.

If you run hdajackretask again, click Remove boot override and then restart system,
that should get audio jack back to original state with headphone output working

Then I suggest you check ALSA information for the headset microphone:

sudo alsa-info.sh --upload

That data will show the ALSA card number for the onboard audio device

The card number can be used with another tool to check the jack detection is working and identify pin number of the microphone connection

I use this command on my system for the onboard audio codec identified as card 1:

sudo hdajacksensetest --card=1

I’d already tried to remove the overrides, but it had no effect.

This is what I get with earphones plugged in:

Pin 0x19 (Black Mic, Rear side): present = Yes
Pin 0x21 (Black Headphone, Left side): present = Yes

So, funny thing is right now is that I have a working microphone but still no headphone output (I’d rather have the contrary).