Header problems when setting up Displaylink

Hi! I am a beginner in Linux and I have recently installed Manjaro with i3. I want to make a dual monitor setup, so I bought a dell d3100 with DisplayLink but I have problems making it work.

I followed the instructions here:

I get stuck at the last step:

xrandr --setprovideroutputsource 1 0

X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 35 (RRSetProviderOutputSource)
Value in failed request: 0x7cb
Serial number of failed request: 16
Current serial number in output stream: 17

But I suspect that the fail is in the previous step, I do have 2 providers, but the second is not a “Sink Output” like in the article.

xrandr --listproviders

Providers: number : 2
Provider 0: id: 0x44 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 2 associated providers: 1 name:modesetting
Provider 1: id: 0x7cb cap: 0x5, Source Output, Source Offload crtcs: 0 outputs: 0 associated providers: 1 name:modesetting

Tried to find a answer but with no success. I suspect that it might be something with the kernel or headers, but I don’t really understand what that is. I will post commands bellow that might give a clue. Would really appreciate help!

systemctl status displaylink.service

displaylink.service - DisplayLink Manager Service
Loaded: loaded (/usr/lib/systemd/system/displaylink.service; enabled; vendor preset: disabled)
Active: activating (auto-restart) (Result: exit-code) since Wed 2021-05-05 18:18:14 CEST; 4s ago
Process: 33291 ExecStartPre=/sbin/modprobe evdi (code=exited, status=1/FAILURE)

yay -S linux-headers-$(uname -r)

Could not find all required packages:
linux-headers-5.6.15-1-MANJARO (Target)

pacman -Q | grep headers

inux-api-headers 5.10.13-1
linux414-headers 4.14.231-1
linux54-headers 5.4.114-1

yay -S evdi

(1/1) Remove upgraded DKMS modules
==> Unable to remove module evdi/1.9.1 for kernel 4.14.231-1-MANJARO: Not found in dkms status output.
==> Unable to remove module evdi/1.9.1 for kernel 5.6.15-1-MANJARO: Not found in dkms status output.
==> Unable to remove module evdi/1.9.1 for kernel 5.4.114-1-MANJARO: Not found in dkms status output.
:: Processing package changes…
DKMS remove…

Deleting module version: 1.9.1
completely from the DKMS tree.

(1/1) reinstalling evdi [##################################] 100%
DKMS install…

Creating symlink /var/lib/dkms/evdi/1.9.1/source →

DKMS: add completed.
Error! echo
Your kernel headers for kernel 5.6.15-1-MANJARO cannot be found at
/usr/lib/modules/5.6.15-1-MANJARO/build or /usr/lib/modules/5.6.15-1-MANJARO/source.
You can use the --kernelsourcedir option to tell DKMS where it’s located.
error: command failed to execute correctly
:: Running post-transaction hooks…
(1/2) Arming ConditionNeedsUpdate…
(2/2) Install DKMS modules
==> Unable to install module evdi/1.9.1 for kernel 4.14.231-1-MANJARO: Missing kernel modules tree.
==> Unable to install module evdi/1.9.1 for kernel 5.6.15-1-MANJARO: Missing kernel headers.
==> Unable to install module evdi/1.9.1 for kernel 5.4.114-1-MANJARO: Missing kernel modules tree.

cat /usr/share/X11/xorg.conf.d/20-displaylink.conf
Section "Device"
  Identifier "DisplayLink"
  Driver "modesetting"
  Option "PageFlip" "false"

cat /usr/share/X11/xorg.conf.d/20-evdidevice.conf
Section "OutputClass"
	Identifier "DisplayLink"
	MatchDriver "evdi"
	Driver "modesetting"
	Option  "AccelMethod" "none"

I tried to follow this guide, and now this folder looks like this:

 ls /usr/src/evdi-1.9.1

ci evdi_debug.c evdi_fb.c evdi_painter.c evdi_platform_drv.h Makefile
dkms.conf evdi_debug.h evdi_gem.c evdi_params.c evdi_sysfs.c mkdocs.yml
docs evdi_drm_drv.c evdi_i2c.c evdi_params.h evdi_sysfs.h module
evdi_connector.c evdi_drm_drv.h evdi_i2c.h evdi_platform_dev.c Kconfig README.md
evdi_cursor.c evdi_drm.h evdi_ioc32.c evdi_platform_dev.h library
evdi_cursor.h evdi_encoder.c evdi_modeset.c evdi_platform_drv.c LICENSE