HDMI Video (driver?) issue with 12th gen N chip

just bought this box.

No matter what I do I can’t get any video to come up after the initial text boot.

The usb stick I am using boots and older 11th gen board no problem.

I even switched to 6.5 kernel but nothing.

Is there some known issue for 12th gen N onboard video? I only found one post that suggested that 5 kernel was too old and suggested a kernel parameter which I tried to no avail.

What ISO are you using exactly?
(or is it a system installed to the USB?)

According to Intel the CPU release is q1 23 - so one is left to ponder if a working driver exist.


When checking the driver page with Intel - only Windows 10/11 appears to be supported.

The download page for Windows says ‘Arc’ and ‘Iris XE’ and for what I know I expect Iris to be supported as some hardware from Tuxedo Computers comes with Iris and preloaded Manjaro.

The specs says ‘Intel® UHD Graphics’

Thanks for the info. I’ll do some more research but as I said I switched to latest kernel available via manjaro and nothing so not hopeful. Sadly this box might have to be returned.

Then again there is this that suggests maybe it should work although maybe not the gen of cpu so much as the video subsystem (that is new?)


I fired up an old linux mint (21.1) with 5.19 kernel and x comes up.

So no this is not a kernel driver problem. So I can only point my finger a manjaro.

This issue (with manjaro) is the same whether I use my portable usb stick I made or trying to boot from the manjaro live iso.

So what could be the issue with x not starting correctly?

Also tried debian bookworm which seems to be fine (at least the graphical install was working). That uses 6.1 kernel

I tried both manjaro kde and cinnamon. Same problem and it doesn’t matter if I choose boot with open source drivers or boot with proprietary drivers.

Well, it’s not a driver issue. If I use the usbc connector for video and not the two hdmi ports supplied then it comes up. Given that this board is intended for laptops and this box is not I assume that the “onboard” UHD video is set to use the usbc video port and not the hdmi ports. I am guessing the hdmi ports are on some “external” gpu and by default Manjaro is not displaying to those even though nothing his hooked up the the usb C.

So it’s a problem specific to my hardware not Manjaro’s fault other than debian can find the hdmi gpu that is connect to monitor and Manjaro can’t. So I wonder if there is way in the boot parameters to tell manjaro to use that other gpu/ hdmi port.

For those finding this and having a similar issue I finally got advice that said to load the 6.6 rc and that fixes it

So for install from install iso you’ll have to use the usbc port but once it’s installed just upgrade to 6.6 kernel (or better) and then you’ll be able to use the HDMI port alone.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.