Hdmi TV wrong resolution plus gdm issue (gnome 45 and wayland)

I have two problems with my laptop connected to TV via hdmi. Inxi details are below, but first a word of the setup. Laptop has screen disabled, only TV is enabled, and latop (below tv) is remotely used with a logitech keyboard/trackpad. Now and then I need to switch from the “basic” used user (by family) to my account for maintenance.


  1. when I switch to one of the text console (example ctrl+alt+f3), the bottom two lines are “below” the bottom tv border. Hence when you write a command, you do not see what you type
  2. when you logout or do a switch user, I only see a “grey” display, but no gdm user selection, no mouse pointer. If I try to play it blind (tab + typing password of other user) I happily login. When I guess it right.

I assume the issue 2) is linked to 1). Suggestions?


P.S. actually which inxi command should I run?

Well then just power it off, so that the TV is the only screen?


video=DP-1:d video=HDMI-1:e

Kernel mode setting - ArchWiki

Hi megavolt thanks for taking the time to answer. That is very kind of you.
Below the result of inxi --admin -v 7 --filter.

As I just run the command on the laptop, I notice ONLY NOW that actually my statement for 2) is not fully correct :slight_smile: . When I “switch user”, gdm activates the laptop screen, and I can see there the users, click on them with mouse and input passwords.

So gdm ignores the “user” setup of only using the hdmi screen and roll back to a more default setup where the laptop screen is the main and the hdmi in the secondary.

I’ll try you suggestion, but with that setup what would happen if I detach the laptop from hdmi and go back to use it as laptop? Will I get a system with no display output?


  Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/sdhc/vmlinuz-6.6-x86_64 root=/dev/mmcblk0p2
    quiet splash
  Desktop: GNOME v: 45.3 tk: GTK v: 3.24.39 wm: gnome-shell dm: GDM
    v: 45.0.1 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 80L0 v: Lenovo G50-80 serial: <filter>
    Chassis: type: 10 v: Lenovo G50-80 serial: <filter>
  Mobo: LENOVO model: Lenovo G50-80 v: 31900058 WIN serial: <filter>
    UEFI: LENOVO v: B0CN72WW date: 01/27/2015
  ID-1: BAT0 charge: 19.9 Wh (100.0%) condition: 19.9/28.5 Wh (70.0%)
    volts: 15.9 min: 14.4 model: Lenovo IdeaPad type: Unknown serial: <filter>
    status: full
  Device-1: hidpp_battery_0 model: Logitech Illuminated Living-Room
    Keyboard K830 serial: <filter> charge: 55% (should be ignored)
    rechargeable: yes status: discharging
  System RAM: total: 8 GiB available: 7.68 GiB used: 2.85 GiB (37.1%)
    igpu: 32 MiB
  Array-1: capacity: 16 GiB slots: 2 modules: 2 EC: None
    max-module-size: 8 GiB note: est.
  Device-1: ChannelA-DIMM0 type: DDR3 detail: synchronous size: 4 GiB
    speed: 1600 MT/s volts: N/A width (bits): data: 64 total: 64
    manufacturer: Hynix/Hyundai part-no: HMT451S6BFR8A-PB serial: <filter>
  Device-2: ChannelB-DIMM0 type: DDR3 detail: synchronous size: 4 GiB
    speed: 1600 MT/s volts: N/A width (bits): data: 64 total: 64
    manufacturer: Hynix/Hyundai part-no: HMT451S6BFR8A-PB serial: <filter>
  Info: model: Intel Core i3-4005U socket: BGA1168 (U3E1) note: check bits: 64
    type: MT MCP arch: Haswell gen: core 4 level: v3 note: check built: 2013-15
    process: Intel 22nm family: 6 model-id: 0x45 (69) stepping: 1
    microcode: 0x26
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1596 high: 1597 min/max: 800/1600 base/boost: 1700/1700
    scaling: driver: intel_cpufreq governor: schedutil volts: 0.7 V
    ext-clock: 100 MHz cores: 1: 1597 2: 1597 3: 1596 4: 1596 bogomips: 13574
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb erms est f16c flush_l1d fma fpu fsgsbase fxsr ht ibpb ibrs
    invpcid lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdtscp rep_good sdbg sep smep ss ssbd
    sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tsc tsc_adjust
    tsc_deadline_timer vme xsave xsaveopt xtopology xtpr
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Lenovo driver: i915
    v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports:
    active: HDMI-A-1 off: eDP-1 empty: DP-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:0a16 class-ID: 0300
  Device-2: Bison Lenovo EasyCamera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:4 chip-ID: 5986:0652
    class-ID: 0e02 serial: <filter>
  Display: server: X.org v: with: Xwayland v: 23.2.3
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: crocus gpu: i915 display-ID: :2 note: <missing: xdpyinfo/xrandr>
  Monitor-1: HDMI-A-1 model: Panasonic Panasonic-TV serial: <filter>
    built: 2011 res: 1920x1080 gamma: 1.2 size: 698x392mm (27.48x15.43") modes:
    max: 1920x1080 min: 640x480
  Monitor-2: eDP-1 model: AU Optronics 0x40ec built: 2013 res: 1366x768
    dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1366x768
  API: EGL v: 1.5 hw: drv: intel crocus platforms: device: 0 drv: crocus
    device: 1 drv: swrast surfaceless: drv: crocus x11: drv: crocus
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.3-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 4400 (HSW
    GT2) device-ID: 8086:0a16 memory: 1.46 GiB unified: yes
  Device-1: Intel Haswell-ULT HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
  Device-2: Intel 8 Series HD Audio vendor: Lenovo 8 driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
  API: ALSA v: k6.6.10-1-MANJARO status: kernel-api tools: N/A
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: n/a (root, process) tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active (root, process)
    with: pulseaudio-alsa type: plugin tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8168 v: 8.052.01-NAPI modules: r8169 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Intel Wireless 3160 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:08b4 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: tun0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> virtual: stable-privacy proto kernel_ll scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:5 chip-ID: 8087:07dc
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 994.74 GiB used: 12.17 GiB (1.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: SR64G size: 59.48 GiB block-size:
    physical: 512 B logical: 512 B type: USB tech: SSD serial: <filter>
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: ST1000LM024 HN-M101MBB
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 0001 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Generic model: Flash Disk
    size: 3.75 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.0
    spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: <filter> fw-rev: 8.07
    scheme: MBR
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GUC0N rev: T.02
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 59.18 GiB size: 14.21 GiB (24.00%) used: 12.17 GiB (85.7%)
    fs: ext4 block-size: 4096 B dev: /dev/mmcblk0p2 maj-min: 179:2 label: N/A
    uuid: 976dc372-9ad1-4d56-9651-2732729dcc19
  ID-2: /run/media/rednose/writable raw-size: 914 MiB
    size: 881.4 MiB (96.43%) used: 1.6 MiB (0.2%) fs: ext4 block-size: 4096 B
    dev: /dev/sdb3 maj-min: 8:19 label: writable
    uuid: ee271847-41eb-4fe1-aa04-7c0d7034e537
  Alert: No swap data was found.
  ID-1: /dev/mmcblk0p1 maj-min: 179:1 size: 300 MiB fs: vfat label: N/A
    uuid: D203-662A
  ID-2: /dev/sda1 maj-min: 8:1 size: 1000 MiB fs: ntfs label: WINRE_DRV
    uuid: 7C08AB0B08AAC38C
  ID-3: /dev/sda2 maj-min: 8:2 size: 260 MiB fs: vfat label: SYSTEM_DRV
    uuid: 9CAD-34EE
  ID-4: /dev/sda3 maj-min: 8:3 size: 1000 MiB fs: vfat label: LRS_ESP
    uuid: FCAF-AFBF
  ID-5: /dev/sda4 maj-min: 8:4 size: 128 MiB fs: N/A label: N/A uuid: N/A
  ID-6: /dev/sda5 maj-min: 8:5 size: 889.42 GiB fs: ntfs label: Windows8_OS
    uuid: 8EE4C22CE4C215FD
  ID-7: /dev/sda6 maj-min: 8:6 size: 25 GiB fs: ext4 label: N/A
    uuid: 90a5fc03-cbab-428b-8164-9c37e75de472
  ID-8: /dev/sda7 maj-min: 8:7 size: 14.76 GiB fs: ntfs label: PBR_DRV
    uuid: 5AD6B4EDD6B4CB11
  ID-9: /dev/sdb1 maj-min: 8:17 size: 2.86 GiB fs: iso9660
  ID-10: /dev/sdb2 maj-min: 8:18 size: 4.9 MiB fs: vfat label: N/A
    uuid: 659D-4321
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 8 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-2:6 info: Alcor Micro Flash Drive type: mass storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s)
    lanes: 1 mode: 2.0 power: 200mA chip-ID: 058f:6387 class-ID: 0806
    serial: <filter>
  Device-2: 1-3:2 info: Logitech Unifying Receiver type: keyboard,mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 98mA
    chip-ID: 046d:c52b class-ID: 0300
  Device-3: 1-4:3 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
    interfaces: 1 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0
    power: 500mA chip-ID: 0bda:0129 class-ID: ff00 serial: <filter>
  Device-4: 1-6:4 info: Bison Lenovo EasyCamera type: video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0
    power: 500mA chip-ID: 5986:0652 class-ID: 0e02 serial: <filter>
  Device-5: 1-7:5 info: Intel Bluetooth wireless interface type: bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1
    mode: 1.1 power: 100mA chip-ID: 8087:07dc class-ID: e001
  Hub-2: 2-0:1 info: super-speed hub ports: 4 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 38.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 303 Uptime: 3h 1m wakeups: 0 Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 902 libs: 290 tools: gnome-software,pamac
  Shell: Bash (su) v: 5.2.21 running-in: gnome-terminal inxi: 3.3.31

Problem here is that GDM (login) and GNOME (session) are different programs with different settings.

Take a look here: GDM - ArchWiki

I would actually assume that the screen of the laptop would be powered off, at least on boot time. But I guess you can activate the screen afterwards.

That is useful für the linux console. For the graphical part, e.g. GDM, see above.

I decided to leave things as they were, but thanks to megavolt, I assume his hint works.
I mark the topic as solved.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.