HDMI Monitor not recognized (Laptop)


HDMI Monitor not recognized

After searching for 4 hours I decided to make a psot. So I have the following problem: I cannot get the second monitor to get recognized by my system. As I plug it in, I get a prompt asking for the display settings but it then disappears. I ran xrandr -q and I can't find any sign about my monitor.

It's a laptop with a discrete graphics card, the one I am currently using should be the Integrated GPU. I also have the nonfree drivers for nvidia.

Here are my system information, would be really happy for any advice !

System:    Kernel: 4.19.81-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=b4419e96-478b-4647-a3a5-05848cd7ead8 rw quiet 
           Desktop: KDE Plasma 5.17.2 tk: Qt 5.13.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: G3 3579 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 03TF0Y v: A00 serial: <filter> UEFI: Dell v: 1.10.0 date: 05/23/2019 
Battery:   ID-1: BAT0 charge: 51.0 Wh condition: 51.0/56.0 Wh (91%) volts: 17.4/15.2 model: BYD DELL 7FHHV95 type: Li-ion 
           serial: <filter> status: Full 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: A (10) microcode: B4 L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 53004 
           Speed: 3565 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 3565 2: 3884 3: 3879 4: 3314 5: 3982 6: 3605 7: 1948 
           8: 3863 9: 3882 10: 3959 11: 1938 12: 3978 
           Vulnerabilities: Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A bus ID: 01:00.0 chip ID: 10de:1c8c 
           Display: x11 server: X.Org 1.20.5 driver: intel compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 19.2.2 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a348 
           Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9 
           Sound Server: ALSA v: k4.19.81-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           chip ID: 8086:a370 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8168 v: 8.047.04-NAPI 
           port: 3000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 144.90 GiB (12.4%) 
           ID-1: /dev/nvme0n1 model: PC SN520 NVMe WDC 128GB size: 119.24 GiB block size: physical: 512 B logical: 512 B 
           speed: 15.8 Gb/s lanes: 2 serial: <filter> rev: 20200012 scheme: GPT 
           ID-2: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 0D scheme: GPT 
           ID-3: /dev/sdb type: USB vendor: SanDisk model: SD8SNAT-128G-1006 size: 119.24 GiB block size: physical: 4096 B 
           logical: 512 B serial: <filter> scheme: GPT 
Partition: ID-1: / raw size: 118.95 GiB size: 116.58 GiB (98.01%) used: 61.74 GiB (53.0%) fs: ext4 dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 286 Uptime: 26m Memory: 7.64 GiB used: 1.67 GiB (21.8%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           clang: 9.0.0 Shell: bash v: 5.0.11 running in: yakuake inxi: 3.0.36 

not all, but most optimus laptops have the external ports wired directly to the nvidia gpu exclusively and your current setup im assuming you chose the "nonfree" drivers during install which would of installed bumblebee. you can use intel-virtual-output but that keeps the nvidia gpu powered on so you have use of the ports or you could setup a different optimus solution which will perform much better.

for intel-virtual-output and other things bumblebee
https://wiki.archlinux.org/index.php/Bumblebee#Output_wired_to_the_NVIDIA_chip
if it works, this command should make the monitor visible.

optirun intel-virtual-output

for other (better IMO) options :point_up:
follow the instructions for whichever you choose, i recommend optimus-switch or prime but you read and decide for yourself.

1 Like

Thanks for the reply, I just switched to optimus-manager ( I read the optimus-switch is new and there is testing required. Everything works great except for one thing; the audio isn't working. Do you have an idea what might be the reason?

yeah, i really need to update the wording on that thread :sweat_smile:. no more testing needed, it works. but if optimus-maanager is already working for you then you should stick with that.

HDMI audio or audio in general?
was it working before? when did it change?

Audio works on the PC, but when I select the monitor as an audio output, it doesn't work. Tried on another monitor and that's the same thing problem.

optimus-manager is working great, guess I'll keep it at least for now!

1 Like

the audio problem is not likely related to optimus-manager so leave that alone.

1st, with the display plugged in and turned on run this from terminal and see if the audio starts to work.

systemctl --user restart pulseaudio

if not, try these:

  • check that audio is not disabled or volume too low on the monitor itself.
  • try a different HDMI cable, they go bad in weird ways and more often that you would think.
  • check the output of aplay -l and see if hdmi audio is listed (post output)
  • install/run pavucontrol and see if your able to enable HDMI audio in the devices section.

I tried it, nothing worked.. I don't think it's a problem with Manjaro, so I will just leave it be for the time being.

Thank you!

1 Like

if you cant figure it out by searching around, create a new thread. there are others far more knowledgeable in pulseaudio than myself.

Forum kindly sponsored by