Hdmi cable woes

Raspberry Pi 4 running Manjaro Arm.

I needed to extend the HDMI cable to the Pi SBC. The supplied original cable did not suit my desk and Monitor setup. A new 2m cable was purchased and installed, but upon boot I get an “Out of Range” warning.
The packaging said it was a 4k HDMI cable. Is this a problem? Do I need to get something else?

This happens when the screen resolution is set to something higher than what the monitor can display.


If I put the old cable back on Manjaro boots fine.

NB I guess that is because it was the cable in use when Manjaro was installed. . .

Does that mean I have to reinstall?

Two links (sorry, in german):


Translate with Firefox-app:

No. The issue is with the hdmi cable whether it is too long or an inferior cable. You did not specify what you were using for a monitor or if it was the same monitor used with the short cable and the long one but you might.

There is a config called config_hdmi_boost=? that is put in config.txt but it seems that it is ignored on the pi4 at this time.




Hmmm. It does not look good. I am using the Raspberry Pi 4B and yes it is the same monitor. I wanted to switch the short (supplied) cable out and fit a longer version. Darn!

Is your cable marked “High Speed HDMI”?

The label says 2M V2.0 4K Male-Male, Micro HD to HD Gold Plated Copper Cable. It has 4K Ultra HD on the packaging.

Update: A new HDMI cable has been puchased at the usual excessive cost, and installed on the Pi. The Monitor returned similar “Out of Range” warnings, but showed signs of life. The screen would flash before going blank. A lot of testing and Googling similar posts took place. The most recent attempt at solving this took 16 reboots. The end result is Manjaro booting to the login screen at the correct resolution. Yay!

The settings applied to config.txt that worked here are as follows.

hdmi_mode=82 - for my resolution 1920x1080

See Troubleshooting a Raspberry Pi HDMI/VGA Adapter | The Pi Hut for more information. Cheers.

Glad you have it working. Did you have a HDMI/VGA adapter inline? Those settings are pretty well standard for that scenario.

Do you just have a TV or a regular computer monitor with out a HDMI/VGA adapter inline and the longer HDMI cable?

Just wondering why the EDID info had to be disabled and having to force the resolution and sound when the only difference was a longer cable.

I had a similar sounding problem after installing the recent new Raspberry Pi OS release:
I have a Raspberry Pi branded micro-HDMI to HDMI cable and that worked fine, but I wanted to use a micro-HDMI to HDMI adaptor + an (older and longer) HDMI cable.

With my preferred cable the monitor showed a blank screen.

I found that adding either of these to /boot/config.txt allowed the monitor to work again:

I’m about to try out the current Manjaro, maybe it will be helpful here too :slight_smile:

I have seen that work around also. Something must have changed with their firmware either with the kernel or RPi’s depending on if you are using kms or fkms. I have noticed some changes here lately. I have a VIZIO tv and have always had to manually specify the display resolution or get a blank screen with the pi4’s. With the other pi devices my tv works just fine.

Yes just a regular monitor - an Asus 1920x1080. There were no adaptors in this case, just the Micro HDMI to HDMI cable.

Thanks for the comments. This thread may be useful to the next person struggling with the same problem.