HDMI Audio isn't working on an Asus Laptop

Recently installed Manjaro and everything is flawless, but HDMI Audio isn’t working.

I’ve got the latest stable and reccomended kernel with the latest NVIDIA propietary drivers.

Specs: i7 6700HQ; GTX 950M; 8GB RAM

Please post the output of inxi -Aazy.

Here it is:


Having both PipeWire and PulseAudio running is a bit strange, but in any case, what’s the output of head -n99 /etc/udev/rules.d/*?


See this.

it’s already there tho

Huh, I missed that entirely. I assume you have rebooted since making that change?

Yup. Rebooted at least 3 times

Interesting, please start sudo udevadm monitor, then run echo 1 | sudo tee /sys/bus/pci/rescan, then post the output of udevadm.

in another terminal?

Yes, udevadm should be running when you run the other command, don’t stop it.

there’s no output.

Please put # in front of the other two lines that begin with ACTION=="add", then reboot, run lspci -d 10de: -nn and post the output.


what if i uninstall pipewire?

I would be surprised if that did anything because the PCI device is not present for some reason, so I think the problem is on a lower level. I don’t think PipeWire has anything to do with it. But you can try, we’ll see.

if I do aplay -l it shows a lot of intel stuff.

Do you want a screenshot?

So, i tried doing a speaker-test on all of the devices and 1 of them worked! But it only played static.

That’s probably the built-in audio device that you can even see in the output of inxi -Aazy.

What do you mean? HDMI audio worked?