HDMI-2 Port Not Detected

Hello. I have been using dual monitors for a few months now with Manjaro 21.0. I use the DP1 and HDMI2 ports, but today the HDMI2 port is no longer being detected by xrandr. I know the HDMI cable is not broken because whenever I unplug it from my laptop, the monitor lights up saying it has been disconnected.

Running xrandr gives the following output: (Note: I am missing HDMI2, not HDMI1)

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080     60.01*+  59.93  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      60.00    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      60.00    59.88    59.85  
   1280x800      59.81    59.91  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   640x360       59.84    59.32    60.00  
DP1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 480mm x 270mm
   1920x1080     60.00*+  50.00    50.00    59.94  
   1680x1050     59.88  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.90  
   1280x800      59.91  
   1280x720      60.00    50.00    59.94  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       60.00    59.94  
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Running inxi -Faz gives the following output:

System:    Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 root=UUID=15622e07-eda6-4dd3-ad3c-ccb6481ca922 
           ro quiet apparmor=1 security=apparmor udev.log_priority=3 
           Desktop: i3 4.19.1 info: i3bar vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Convertible System: LENOVO product: 81CU v: Lenovo YOGA 730-15IKB serial: <filter> 
           Chassis: type: 31 v: Lenovo YOGA 730-15IKB serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <filter> UEFI-[Legacy]: LENOVO 
           v: 7KCN32WW(V1.13) date: 05/22/2020 
Battery:   ID-1: BAT1 charge: 34.8 Wh (84.1%) condition: 41.4/51.6 Wh (80.3%) volts: 12.7 min: 11.2 
           model: 0x43 0x65 0x6C 0x78 0x70 0x65 0x PABAS0241231 type: Li-ion serial: <filter> 
           status: Charging cycles: 548 
CPU:       Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake note: check 
           family: 6 model-id: 8E (142) stepping: A (10) microcode: E0 cache: L2: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808 
           Speed: 749 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 749 2: 748 3: 791 4: 719 5: 748 
           6: 791 7: 751 8: 754 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:5917 class-ID: 0300 
           Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo bus-ID: 1-5:5 
           chip-ID: 13d3:56b2 class-ID: 0e02 
           Display: x11 server: X.Org 1.20.10 compositor: picom v: git-dac85 driver: loaded: intel 
           unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
           Monitor-2: DP1 res: 1920x1080 hz: 60 dpi: 102 size: 480x270mm (18.9x10.6") diag: 551mm (21.7") 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403 
           Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.23 running: yes 
Network:   Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: Lenovo ThinkPad E595 
           driver: rtw_8822be v: N/A modules: rtw88_8822be port: 3000 bus-ID: 3a:00.0 chip-ID: 10ec:b822 
           class-ID: 0280 
           IF: wlp58s0 state: up mac: <filter> 
Bluetooth: Device-1: Realtek RTL8822BE Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8 bus-ID: 1-7:7 
           chip-ID: 0bda:b023 class-ID: e001 serial: <filter> 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 931.51 GiB used: 77.42 GiB (8.3%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P5SSD8 size: 931.51 GiB 
           block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD 
           serial: <filter> rev: P4CR324 temp: 35.9 C scheme: MBR 
Partition: ID-1: / raw-size: 931.51 GiB size: 915.89 GiB (98.32%) used: 77.42 GiB (8.5%) fs: ext4 
           dev: /dev/nvme0n1p1 maj-min: 259:1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 208 Uptime: 31m wakeups: 3 Memory: 7.5 GiB used: 1.95 GiB (26.0%) Init: systemd 
           v: 247 tool: systemctl Compilers: gcc: 10.2.0 Packages: 1431 pacman: 1424 lib: 419 flatpak: 0 
           snap: 7 Shell: Bash v: 5.1.0 running-in: terminator inxi: 3.3.03

Running sudo mhwd -li outputs:

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
Warning: No installed USB configs!

I appreciate any help with this issue. Thanks!

Welcome to the forum! :wave:

When pasting terminal output, highlight it and use the Preformatted text </> button, not the Quote " button.

Alternatively, add three backticks ` above and below the text:


Please edit your post accordingly.

I just reformatted the post. Thanks!

Have you tried another cable? Have you tried connecting the monitor to another port either on the same machine or another?

Yes, I have tried a new cable and also tried the current cable on another a different machine, and it works fine. I don’t have another port on my current machine. I also believe the port on my current machine is working because whenever I plug the cable in, the monitor lights up. However, the monitor says the port it has been plugged into is inactive.

FYI, that kernel was EOL (End Of Life) last December. I suggest installing the latest stable kernel (5.11) or an LTS kernel (5.10 or 5.4). It’s good to have more than one installed as fallback.