Having trouble dual booting Manjaro kde plasma along side windows 10

Okay so I wanted to dual boot windows and manjaro but after all the manjaro installation process it asked me to restart , which I did and then my laptop boots into windows and when I go to my bios, I can’t see the manjaro option. I asked my friends about this and they suggested me to use easy bcd, but when I used it, an error pop us prompted saying that the windows was booting in efi mode and hence the features of easy bcd is limited. So I couldn’t use the easy bcd method. Please help me.
Thank you.

Hi and welcome to the forum :wave:

Edit: Omano has a better first awnser

1 Like

Did you read that before trying to dual boot Windows 10 and Manjaro?


hey brother omano. i had done everything according to your instructions but i didnt do the CMD part. so i tried that and rebooted and i still couldnt find the manjaro. and also the link of gohlips forum is too hard for me to understand it because i am just a beginner to linux as well as windows. please help me and here is a photo, could u please tell me is disabling it would do anything to help the problem i am having?

also brother, can i trust this youtube video for dual boot installation cuz i followed this youtube video

hey i am expecting a reply from u brother

What is the issue exactly? You don’t boot on Manjaro? You directly boot to Windows?

i dont boot to manjaro, directly boot into windows , and then when i enter my bios , manjaro is not seen

Did you select the Manjaro disk in the BOOT menu of your BIOS?

//EDIT: at this point show a picture of all your BIOS menu, explain in most detail possible your setup and what you have done, or else we’ll be at it in two weeks if we play the guess game.

The Manjaro disk itself is not there , I’ll show u a picture so that you could have a better understanding

I am a newbie and I don’t know anything about computers, but I am super interested in learning it. So here is what I did exactly from the start.

First I downloaded the Manjaro kde and then flashed my usb stick using the software Rufus. Then I created the disk partition, which you can see below I have uploaded the picture of my disk partition. And then I booted into Manjaro kde and then installed it properly by following a video. https://youtu.be/PYqQ99tyxBA

I used this video to create the partition. And then it proceeded to install. After that it asked me to reboot my device. So I rebooted and unplugged my usb stick once my screen turned off. it directly booted into my windows and it didn’t take me to the bios or grub(the thing where it asks us to choose from windows and manjaro). It didn’t take me there. So I checked the bios and there was only windows there and nothing else.

I am really sorry if I trouble you too much but I do not know where my problem is. Please help me, it would mean a lot

Thank you for your help

So what I did now is I plugged in the usb which has manjaro and I entered bios and booted into manjaro. So I did the installation process from the start again and when I reached the partition part I saw that the manjaro is actually indeed already installed and I thought it would be stupid to do it again here is the picture.

And also one thing I realized that mine was different from the YouTube videos I saw and it was this

It asked me for two options here. Normally people get prompted with one option but I got 2 drivers. I checked online but it said it wasn’t a problem. I just asked you to confirm since you are a professional.

So you have a laptop with one only disk… that’s not the same.
For the boot option from the USB, this is normal, the options are self explanatory, one boots with open source drivers, the other boots with proprietary drivers (Nvidia). It changed since long time now.
I will not look at your video. I gave a great guide already this is what you have to follow.

Is there a reason you have 8 partitions (which you cut the important information I guess in your picture)?

Also if you have one disk only, then both systems need to share the boot partition, not sure it is properly covered in the guide. I’m really not sure you read the entire guide and followed it, you keep talking about following your video.

I would start over, delete every partition which is not from Windows, keep your boot partition from Windows, keep the other partitions from Windows, and select the Windows boot partition during the installation of Manjaro, create one partition for Manjaro with the free space.

I never installed multiple systems on one disk so I don’t know.

The video is exactly as same as the guide you gave me. And yes I READ the entire guide and I came to the conclusion that the video and the guide is the SAME. And I didn’t understand the last para and the para before it which u sent cuz like I told you I don’t understand the terminologies. So I guess Linux is not for me and I give up. If you have any other link that could help me. I would look into it. If not, then thank you for your time.

Delete existing manjaro partitions…including the 500mb no label Fat32 one.
Don’t make another efi partition
Use existing 100MB Fat32 partition…set mount point /boot/efi and add flag ‘boot’…don’t format it.
Make a root partition…mount point’ / '…flag ‘root’
Make a ‘linuxswap’ partition…flag ‘swap’

Now install Manjaro and reboot

So in simple words I have to delete all the partitions I have right now and then what do I have to do, I didn’t understand that part. I’m noob. If you have a video that I could follow or a guide or anything it would be great for me bro.

Delete the nvme0n1p5,p6,p7,p8 from live usb u already have

Select nvme0n1p1 and Click edit…set mount point /boot/efi and flag ‘boot’ & don’t select format option…select the ‘keep’ option(already selected)

Now select the large free space u have and click on create…Allocate 4100 MB space & set File System as ‘linuxswap’…click on ok or save or whatever.

Now select the large remaining space u have and click on Create…set mount point ’ / ’ …click ok or save or whatever.

U r now good to go
Install and reboot

As I understand, the issue is not solved yet. I had a similar issue when after the first boot into the system, Manjaro vanishes from the BIOS boot menu. That archived forum thread helped me:

The issue, according to that forum thread, might be that BIOS doesn’t let and OS called “Manjaro” boot. The solution in this thread was to reinstall the grub under the name “Ubuntu”. On my system BIOS only accepts “Ubuntu” and probably “Fedora” (did try to install Fedora, it didn’t have the issue) but nothing else (e.g. “Red Hat Enterprise Linux” or “Manjaro”) except Windows Boot Manager.

I hope it helps (step by step instruction is in the end of the thread). Good luck!!

P.S. Every time I see something related to grub in updates I redo the install with id=Ubuntu, since the system boots via “Ubuntu” folder not “Manjaro” which probably gets the update.

Btw, Live USB doesn’t show me availiable bootloaders, if Windows is first in the boot order. If you put it second, Live USB will show you every bootloader in the boot sector (EFI partition).

My machine is Lenovo G50-70.

1 Like

Hi Marko, how are you? thank you so much for helping me. but please tell me “Ultimately I had quite a few directories in /boot/efi/EFI due to my many attempts to get things going. Using efibootmgr -b (entrynumber) -B I first deleted what I thought was an unneeded entry, followed by physically removing the directory itself from /boot/efi/EFI.” how does he remove the driver. do i have to go to the powershell and do it or install manjaro all over again and then use the linux terminal for deleting the driver? or idk what do i do?. i am genuinely happy that i see that people have the same problem as i do but the thread u gave me is too hard for a newbie like me to understand, but i cant thank u enough for showing me this thread. please simplify it if you can. Thank you SO MUCH

Hi Thatshab!. I am a newbie myself. Started trying Linux Mint as a daily driver in the beginning of march. Learned a lot in the process. Actually when I read this article the first time, I stumbled exactly at the same place. Maybe I should start with the explanation of the premise.

BIOS is a programmed chip on the motherboard which looks into the boot sector, finds a bootloader (a small program which boots the OS) and launches it. After that OS takes over and finishes the process of initializing.

If there are multiple bootloaders (folders named “OS” with the bootloader file in the EFI partition (how boot sector/partition is called), in Linux /boot/efi/ points to it, in Windows it is hidden). If you have more than one bootloader there, BIOS puts them into the priority list and launches them in that order (devices as DVD and USB drives are in this queue as well), or the way the manufacturer programmed it. In my case it seems to ignore “Manjaro”, even if it is there, so I am unable to put it first or boot directly into it from Boot Menu of the BIOS software. It seems to be an intentional blocking of specific OS names by the manufacturer. Probably manjaro bootloader is there, so don’t worry.

Under the “end of the thread” I meant the end of the discussion I sent. There, the guy who had issue was removing bootloaders using a special command line tool, since he was testing the issue and had a lot of bootloaders accumulated. He suspected that the BIOS software might have programmed limit for possible number of bootlaoders you can have. This is not the issue right now probably, since you have only 2 OS-s. OP (original poster) did the simplification fortunately himself later in the discussion - detailed step by step instruction is marked as 58/67 post in the forum. The post you were looking at is 42/67.

In my case, I had already installed Manjaro for the n-th time, when I finally followed the discussion through till that post (58/67). Since I had Manjaro already installed I continued starting from the 10. in the post. If your PC skips Manjaro Live USB bootloader menu (11.) just click restart in the Live USB testing OS environment when you get booted in, and it will reboot into the bootloader menu again.

*the command line interface in Linux is called a terminal. Powershell is the thing Windows has. The serve similar purpose but they are not the same.

For me, I was able to boot into Manjaro under the name of “ubuntu” after I booted into my existing installation of Manjaro via Live USB as described in 11. and 12.; performed reinstallation of grub (name of linux bootloader) under the “id” of “ubuntu” in the terminal as described in 13. and 14. (that command rebuilds grub boot menu, where you can choose where you want to boot into).

After that I was able to boot into Manjaro under the name (in the bios menu) of “ubuntu” as described in the manual of discussion entry 58/67.

I hope it helps you back on track. (me putting a link, which refers to 42/67 instead of 58/67 was my mistake. Didn’t realize, it being the issue, since I eventually followed through with the discussion when I was dealing with the problem at hand)

1 Like