Having trouble booting up my dual boot laptop

I am having trouble booting up my dual boot laptop, One SSD has Windows11 & the other SSD has manjaro. If I remove one of the SSD, then the computer boots up. but when both SSD is installed it gives me a Grub error screen. I tried to use a USB with Zorin 16 to do the Boot repair, It did not work either, This is the error file that Zorin gave me:

Any help is appreciated.

Is it the SSD containing Windows that boots successfully?

If so, remove it, or disconnect it. With only the second SSD (containing Manjaro) connected, boot with the Manjaro installer DVD/USB and completely reinstall Manjaro, and make sure its installed using EFI and not MBR.

After Manjaro is installed and operating as expected, shut down, power off, and reconnect the Windows SSD (so that both SSDs are once again connected). Boot to your BIOS settings and ensure that the Manjaro SSD is first in boot order. Exit your BIOS, and your machine should reboot to Manjaro’s Grub which should now list Windows among its boot options. Don’t panic if it doesn’t, as this can still be solved afterwards.

Report back when done.

Note; this assumes it’s a new Manjaro installation without data you don’t wish to lose.


1 Like

I think you are missing the sudo update-grub portion.

I did re install the manjaro as per your instruction, and every restart was taking to manjaro.Then I tried the ‘sudo grub-update’ comment from cscs and the next restart came up with the grub page with options and now I can boot up in windows also.
Thank you.

Thank you, the update-grub worked.

Sorry, I wrongfully assumed you would have known to do that. :slight_smile:

sudo update-grub

The default repair of the Boot-Repair utility would not act on the MBR.
Additional repair would be performed: win-legacy-basic-fix

It seems to try to use MBR not EFI.
I won’t intervene in the thread more than that, but thought that info could be useful.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.