Having some issues with NVIDIA drivers

Just finished with the main install and I don’t seem to be able to use anything other than the open video drivers. The steps in the wiki in regards to this fail.
What info’s required here?
Any assistance is greatly appreciated,

What in the wiki?

Configure Graphics Cards - Manjaro

What is your system?

How to provide good information

The very first thing in it to be honest. (I’m going to have to paste this in pieces because I can’t work out which part the forum thinks is a link I’m not allowed to post.)

When I run the command sudo mhwd -a pci nonfree 0300 I get this return:

    > Using config 'video-hybrid-intel-nvidia-418xx-bumblebee' for device: 0000:00:02.0 (0300:8086:0a16) Display controller Intel Corporation Haswell-ULT Integrated Graphics Controller
    > Installing video-hybrid-intel-nvidia-418xx-bumblebee...
    Sourcing /etc/mhwd-x86_64.conf
    Has lib32 support: true
    Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-418xx-bumblebee/MHWDCONFIG
    Processing classid: 0300
    Sourcing /var/lib/mhwd/scripts/include/0300
    :: Synchronizing package databases...
    warning: xf86-video-intel-1:2.99.917+913+g9236c582-1 is up to date -- skipping
    error: target not found: linux59-nvidia-418xx
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
    Error: pacman failed!
    Error: script failed!

Now to provide good information (bit by bit):
Output of Inxi -Fazy:
Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64
root=UUID=f7732621-e6ec-477c-b190-ad461825e4aa rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Manjaro Linux

yeah … your kernel is too high … and the old nvidia drivers might become fully deprecated soon.

Soo … first thing … update:

pamac upgrade

then get an older kernel … hopefully 5.4 LTS is old enough:

sudo mhwd-kernel -i linux54

Then reboot (select 5.4)… and have a look at your driver options again … choose what works for you.

Just know that bumblebee is legacy, and the 418 series is dying … so in true nvidia form … you might simply be out of luck soon enough and have to rely on the open drivers.

1 Like

Ah, that sounds about right. Cool, so long as I can still offload on to the GPU it’ll work for me. Learning how this all works on an old laptop so the more obstacles I encounter the more opportunities I have to learn.
Thanks heaps.

If you end up using nouveau (the reverse-engineered open driver for nvidia) then you dont really need anything but the regular open drivers (provided by video-linux in mhwd) … then its the same, but not requiring a wrapper script or anything (same as on, say, AMD):

glxinfo | grep 'renderer string'
DRI_PRIME=1 glxinfo | grep 'renderer string'

or, for as long as you have bumblebee you can be using primusrun or optirun rather than DRI..)

Can you post the available drivers for your hardware?

mhwd --list

As said drivers will soon have big changes in Manjaro so let see if you’ll be one of the lucky or not so lucky ones.

Will it be possible to have hardware accelerated video decoding in Chromium and/or Firefox using nouveau?

Reason for asking: If I recall correctly, nouveau used to have no suppport for any hardware acceleration on Nvidia whatsoever. I would be more than happy if that is not true anymore :slight_smile:

Nouveau supports both vaapi and vdpau, so ostensibly it should be possible … as to the particulars of browser I am not sure.

Some time ago, I tried exactly that, following several recommendations.
Looks like nouveau does not detect my good old Nvidia 550 GTX.
At least I got that favored error message “Unable to start LightDM Display Manager” after having installed video-linux in mhwd.

Fortinately, I could get the system working again by installing the 390 non-free Nvidia driver.

390 is the only one still going besides nvidia (current - 455)
As long as it works its probably going to give better performance than nouveau.

There seems to be at least two aspects worth mentioning about the Nvidia driver 390.

First, on each update, the file /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf is being reset to default contents after each update, and the following entries are missing:

    ModulePath "/usr/lib/nvidia/xorg"
    ModulePath "/usr/lib/xorg/modules"

This results in GLX configuration to get broken:

[     4.293] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[     4.293] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[     4.293] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[     4.293] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[     4.293] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.

As a result (among others), you will get errors starting the xfce desktop environment:

Unsupported GL renderer (llvmpipe (LLVM 11.0.0, 256 bits))

Second, for some reasons, nvidia_uvm has been removed from the Nvidia driver 390.