Having problems with kde zoom and screen edge presenting windows

By kde zoom I mean the desktop effect setting which is normally bound to Meta+=.
They both worked until recently and I tried changing the screen edge and what kind of window presenting in settings.
I realize this is not much information but I don’t know what is actually relevant so I will just try to answer questions.

Thank you for your time.

  • Are the effects still enabled in your desktop effects settings?

  • Is your compositor running?

When I go to compositor in settings it gives me a button to re-enable OpenGL detection with the risk of an immediate crash and an unchecked checkbox to enable compositor on startup.
I should also mention that other desktop effects still work and other screen edge things still work.
As far as I can tell the effects are enabled.

That means your compositor isn’t running.

Without the compositor, you cannot has desktop effectses, Preciousss. :stuck_out_tongue:

But why do other ones still work?

Which ones?

Wait no none work and I was going crazy, however I checked that checkbox and it still doesn’t work after reboot
applications are also able to block the compositor in case that matters

Maybe your graphics adapter is no longer supported by OpenGL. Which one do you have?

Sorry, how do I check that?

inxi -F

Can you try switching to OpenGL 3.1 in Compositer Settings

Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
Display: x11 server: X.Org driver: loaded: modesetting
resolution: 2256x1504~60Hz
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.3.2

Ok I just tried that and after rebooting its still not working

Do you have xf86-video-intel installed? If not, then you can try installing that… :arrow_down:

sudo mhwd -i pci xf86-video-intel

Error: config ‘xf86-video-intel’ does not exist!

Ok I just did sudo mhwd -l and got back:

0000:00:02.0 (0300:8086:9a49) Display controller Intel Corporation:

              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI
 video-modesetting            2020.01.13                true            PCI
        video-vesa            2017.03.12                true            PCI

don’t know if that is helpful I am just trying to get more info

The package is still in the repos. Okay, try this then… :arrow_down:

pamac install xf86-video-intel

it said it was up to date

Ok after switching to OpenGl 3.1 in Compositor settings and back to OpenGL 2.0 it appears to have been fixed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.