Having problem with optimus card after the update


In the past I had a problem with my laptop due to the fact it contains an optimus card.
I solved the problem then thanks to help of Manjaro community and NVidia forum (details: Problems with hybrid NVidia RTX 3070 in Linux - #15 by generix - Linux - NVIDIA Developer Forums).

Today I updated Manjaro (Gnome edition) and after the update the problems with graphics card returned.

I have an external screen attached to my laptop via HDMI cable. It works fine. However, after the update the resolution of my built-in display returned to the highest possible (2560x1600). When I try to lower it, the built-in screen starts flickering and I can’t see a thing.

As I said, everything worked fine until today’s update. Has anyone observed a similar issue?

1 Like

Hi, I have exactly the same problem after the last BIG update (but with an AMD GPU and not external display).

I was able to reproduce this problem using timeshift:

1.) Go back in time before the big upgrade to:

  1. Resolution no longer customizable, maximum resolution automatically selected,
    all other resolutions with wrong Hz number and graphics flickering

If someone could help us with this, this would be very great
Many thanks! :slight_smile:

1 Like

Hi team,
i only wanted to say that the latest Updates, fixed the problem (for me).
Might be a issue with Gnome / GPU Drivers, i really don´t know.

I hope that this information will help you out, if you had the same issues like me and op(?)


1 Like


Yes, I confirm that the update fixed the issue for me as well.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.