Having issues with OBS Studio

Hi all, I’m having some issues with OBS Studio and I don’t know if it’s an OBS problem or a Manjaro problem.
Fair warning; I’m reasonably novice when it comes to the command line.
Trying to run OBS from the CL yields this:

   ~  obs studio  :heavy_check_mark:
debug: Found portal inhibitor
debug: Attempted path: share/obs/obs-studio/locale/en-US.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
debug: Attempted path: share/obs/obs-studio/locale.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale.ini
debug: Attempted path: share/obs/obs-studio/locale/en-GB.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale/en-GB.ini
info: Using preferred locale ‘en-GB’
debug: Attempted path: share/obs/obs-studio/themes/Yami.qss
debug: Attempted path: /usr/share/obs/obs-studio/themes/Yami.qss
warning: [Safe Mode] Unclean shutdown detected!
info: [Safe Mode] User has launched in Safe Mode.
info: Command Line Arguments: studio
info: Using EGL/X11
info: CPU Name: AMD Ryzen 7 2700X Eight-Core Processor
info: CPU Speed: 2724.283MHz
info: Physical Cores: 8, Logical Cores: 16
info: Physical Memory: 32044MB Total, 25134MB Free
info: Kernel Version: Linux 6.1.62-1-MANJARO
info: Distribution: “Manjaro Linux” Unknown
info: Desktop Environment: KDE (KDE)
info: Session Type: x11
info: Window System: X11.0, Vendor: The X.Org Foundation, Version: 1.21.1
info: Qt Version: 6.6.0 (runtime), 6.6.0 (compiled)
info: Portable mode: false
warning: Safe Mode enabled.
info: OBS 30.0.0-1 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
samples per sec: 48000
speakers: 2
max buffering: 960 milliseconds
buffering type: dynamically increasing
info: ---------------------------------
info: Initializing OpenGL…
info: Loading up OpenGL on adapter NVIDIA Corporation NVIDIA GeForce RTX 3070/PCIe/SSE2
info: OpenGL loaded successfully, version 3.3.0 NVIDIA 535.129.03, shading language 3.30 NVIDIA via Cg compiler
info: ---------------------------------
info: video settings reset:
base resolution: 1920x1080
output resolution: 1280x720
downscale filter: Bicubic
fps: 30/1
format: NV12
YUV mode: Rec. 709/Partial
info: NV12 texture support not available
info: P010 texture support not available
info: Audio monitoring device:
name: Default
id: default
info: ---------------------------------
warning: Failed to load ‘en-US’ text for module: ‘decklink-captions.so’
warning: Failed to load ‘en-US’ text for module: ‘decklink-output-ui.so’
libDeckLinkAPI.so: cannot open shared object file: No such file or directory
warning: A DeckLink iterator could not be created. The DeckLink drivers may not be installed
warning: Failed to initialize module ‘decklink.so’
warning: Skipping module ‘frontend-tools’, not on safe list
info: [pipewire] Available captures:
info: [pipewire] - Desktop capture
info: [pipewire] - Window capture
warning: v4l2loopback not installed, virtual camera disabled
info: NVENC supported
zsh: segmentation fault (core dumped) obs studio

Is anyone able to decipher this gobbledegook for me, please?
Thanks in advance.

Might I take a wild guess and assume you are using the native Manjaro package?

When I was trying to get pipewire screen/audio capture to work, I never found a solution. It is heavily relying on chrome stuff. IIRC I was in a discussion about it here on the forum and basically got, “if you want those extensions to work you have to fix it yourself”.
I switched to the flatpak version and everything works.


For what it is worth - the obs-studio in the repo is inherited from Arch.

If you need other variations for a some given functionality you will have to resort to custom script from AUR.

The reason - as I recall it - is the rolling release concept which way too often breaks functionality in the Arch package.

These hickups has made upstream Arch to exclude the that functionality to keep the repo package stable.

This is creating a gap - I think (not a user - but reading the forum) it is primarily some browser integration which is creating the hickups.

From memory, I went to manjaro.org and clicked on “Get manjaro”. Is that what you mean by native package?

linux-aarhus, is that a good thing or a bad thing?

I mean you used pamac or pacman to install OBS studio from the Manjaro repositories. Uninstall that and install the flatpak version of OBS.

Oh, ok. I’ll give that a shot.
Before I moved to manjaro, I was on Mint for 6 years, and I found that flatpaks gobbled up insane amounts of hdd space. Is there a way to manage that?

Yes - remove unused flatpaks - the space occupied - that is how it is.

It’s the nature of flatpaks. They are containered so they need to install everything needed for that, drivers, desktop etc fore each program. They can share those dependencies within flatpak, if they use the exact same version.

The best way to keep flatpak footprint small is to use as few as possible and constantly keep it updated with flatpak upgrade and flatpak uninstall --unused

1 Like

Thanks guys, much appreciated!

Since you are so nice…

sudo pacman -Rsun obs-studio
flatpak install com.obsproject.Studio

Good luck!

Haha! Thanks Bedna!