Having issues and inconsistences when trying to play Steam games

Hello, everyone. I’m getting a handful of issues when trying to make Steam games work with my installation of Manjaro. Before I list the issues I’m having, I will try to explain how things are setup on my PC: I am dual booting Manjaro 21.1.2 with Windows 10 (UEFI installation), both systems installed on my main NVME drive. Specifically, I’m using the KDE version (5.22.5), and right now I’m using Kernel 5.13 but I have also used the LTS 5.10 kernel after reading here on similar issues that the LTS kernel could help. Also, I’m using the version of Steam that ships with Manjaro (I used the standard ISO, not the minimal version), together with Wine, Winetricks, Wine Stable 4 and Wine Staging 4 installed first by the GUI method and then when things didn’t work out as expected through the terminal, according to this tutorial, which basically adds all the libraries by hand just to be sure.

So, now, for my issues:

1. Running games installed on a NTFS partition:

I have all of my W10 Steam games installed on a second sata SSD, and I’ve heard I could get them to work on Manjaro with a few tweaks. So first I’ve made the main NTFS partition of this drive mount on startup, and filewise everything seems to work fine. Them I created a mount point by editing fstab according to this Proton tutorial. My fstab file now reads

<file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=80EC-4057                            /boot/efi      vfat    umask=0077 0 2

UUID=cbe7fc6f-d8ec-4056-8eba-b2e9b8aeac47 /              ext4    defaults,noatime 0 1

/dev/disk/by-uuid/E692216D92214381 /media/gamedisk ntfs, uid=1000,gid=1000,rw,user,exec,umask=000 0 0

where the last line is the one I’ve edited to create a mount point on a /media folder (yes, my uuid is 1000, same for the gid, and I also have ntfs-3g installed, I checked that). I also had to use a chown to change permissions on the /media folder. At first, everything works fine with the mount point, Steam recognizes it’s old SteamLibrary folder and all, but most of my games will start their “First Time Setup” when they install Microsoft VC Reddist and all that stuff, and then close. What is more confusing is that I’ve managed to make one single game (Nier Automata) which is installed on this partition through Windows, to run flawlessly, but not others. So, what I tried to do was to create a ext4 partition on this drive to install things there, figuring ntfs just wouldn’t work well. I then shrinked the ntfs partition and created a new one as ext4, and also created a mount point for it by changing fstab to include the line

/dev/disk/by-uuid/20b73875-495a-4d52-8672-437dd51f5c6e /media/Backup auto nosuid,nodev,nofail,x-gvfs-show 0 0

which again, works quite inconstently with a similar issue: some games will launch and run, others will “launch”, do the first time setup and then close. So I guess the partition type wasn’t creating this issue, it must be something else, which I don’t know what might be. I’ve tried the two latest versions of Proton, 5.13 and 6.3, and it is still hit or miss with the first time setup issue.


2. Getting a Xbox One Controller to work properly:

This one is weird, as I’m using a wired controller, but I can’t get vibration to work at all. I’ve checked for solutions for this online but couldn’t find any. It’s a small annoyance but still, it should work. On KDE I have access to system settings > input devices > controller, but I have no option to setup vibration or something like that.

Thanks in advance and sorry for the long post. I tried to be as much detailed as I could.

I don’t use (and don’t recommend) NTFS for my Steam libraries. If you have some game work, and some other not, then try to troubleshoot each game one by one, making sure they work on ProtonDB, or don’t need extra parameters (also check issues on Proton GitHub).

It simply works. Make sure you don’t have weird config in Steam Settings, there are ‘overrides’ for controllers. You don’t need that. I could check again but last time I used the controller, it was working as intended, out of the box.
//EDIT: it is a ONE controller you have, this is not what I have, so then maybe try to mess in Steam Settings and the various controller configuration available.

From my experience, “converting” a Windows-installed Steam game into Linux-compatible one isn’t as smooth as simply redownloading the game.

The launch-then-stop issue reminds me of this, although i’m not sure it relevant for your case:

Regarding your controller, have you tried installing xboxdrv?

I’m starting to think this is related to save location. For example, one of my games that don’t work has it’s save located by default under my C: user folder. I guess I will have to troubleshoot each one on ext4 then, which was what I was trying to avoid. About the controller, at least now I know that it should work. I will fiddle with Steam latter to see if there is some configuration overriding and try @maycne.sonahoz advice.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.