Have to restart vmtoolsd.service at login every time to get correct display


Every time I log in to my desktop (Cinnamon) it gives me the 800x600 resolution. I have to run the following command every time:

systemctl restart vmtoolsd.service

and it brings up the correct display. Is there a way around this so I don’t have to run it every time?

Is the service enabled? If no then you can make it so that it runs everytime on boot:

systemctl enable --now vmtoolsd.service

Yes, it’s enabled. This is a virtual machine on VMware workstation and has a display of 1918x920. Not sure if I need to add that somewhere.

I found the solution:

So. You don’t need to modify service file. The only thing to do is load modules:


MODULES=(vsock vmw_vsock_vmci_transport vmw_balloon vmw_vmci vmwgfx)

sudo mkinitcpio -P

Credit here:

1 Like

Thanks - this worked for me.