Have to press shortcut twice to change keyboard layout

Hi everyone,

I’m new here and I have a weird problem on Manjaro Gnome 21.1.6 with keyboard layout switching. I have 2 layouts - Russian and English and a shortcut ctrl+shift set in gnome settings. And to change to English layout I have to press ctrl+shift twice. So if I cyclically change layout and press, for example, “q” key, I get: qййqййqййqй.

Strange thing, I have deleted Russian layout in the settings, and now layout switching works fine (ctrl+shift shortcut). But standard win+space shortcut doesn’t work and there is no indicator in the panel. I guess, there is another language setting outside of gnome…

Reinstalled Manjaro without choosing Ru keyboard layout in calamares. When i set custom shortcut in gnome tweaks, I can now switch to russian without setting it somewere else…

Solved this problem. Command to set up a layout change shortcut:

gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Ctrl>Shift_L']"

(and disabling shortcut in gnome tweaks)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.