Has anyone been able to get audio working on XPS 17 in kernel 5.8+?

They were working before, I’m quite sure, but a few days ago the soundcard has also ceased to function for 5.7.17. I’m not completely sure what kind of information I should include for a resolution.
pulseaudio is 13.99.1 as this thread recommended; I also followed these instructions, but they broke after the latest update and I haven’t been able to get them working since. my ALSA dump is here, and inxi -Fxz returns

System: Kernel: 5.8.3-2-MANJARO x86_64 bits: 64 compiler: N/A Desktop: KDE Plasma 5.19.4 Distro: Manjaro Linux
Machine: Type: Laptop System: Dell product: XPS 17 9700 v: N/A serial:
Mobo: Dell model: 0P1CHN v: A00 serial: UEFI: Dell v: 1.0.6 date: 07/27/2020
Battery: ID-1: BAT0 charge: 92.2 Wh condition: 92.2/95.1 Wh (97%) model: BYD DELL F8CPG05 status: Full
CPU: Topology: 8-Core model: Intel Core i7-10875H bits: 64 type: MT MCP arch: N/A L2 cache: 16.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 73625
Speed: 3065 MHz min/max: 800/5100 MHz Core speeds (MHz): 1: 879 2: 926 3: 803 4: 828 5: 1255 6: 813 7: 922
8: 835 9: 1198 10: 1172 11: 1247 12: 810 13: 1435 14: 1219 15: 1244 16: 824
Graphics: Device-1: Intel UHD Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
Device-2: NVIDIA TU106M [GeForce RTX 2060 Max-Q] vendor: Dell driver: nvidia v: 440.100 bus ID: 01:00.0
Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-5:4
Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia resolution: 3840x2400~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.1.6 direct render: Yes
Audio: Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3
Sound Server: ALSA v: k5.8.3-2-MANJARO
Network: Device-1: Intel Wireless-AC 9462/9560 vendor: Bigfoot Networks driver: iwlwifi v: kernel port: 4000
bus ID: 00:14.3
IF: wlan0 state: up mac:
Drives: Local Storage: total: 1.86 TiB used: 76.54 GiB (4.0%)
ID-1: /dev/nvme0n1 model: KXG60PNV2T04 NVMe KIOXIA 2048GB size: 1.86 TiB
Partition: ID-1: / size: 1.77 TiB used: 76.52 GiB (4.2%) fs: ext4 dev: /dev/nvme0n1p2
Swap: ID-1: swap-1 type: partition size: 68.79 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p3
Sensors: System Temperatures: cpu: 68.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0 fan-2: 0
Info: Processes: 334 Uptime: 1h 45m Memory: 62.53 GiB used: 2.63 GiB (4.2%) Init: systemd Compilers: gcc: 10.2.0
Packages: 1294 Shell: Bash v: 5.0.18 inxi: 3.1.05

School starts soon, and sound would be necessary for online courses. Any help appreciated.

Your ALSA data has a list of !!All Loaded Modules
but that list is not showing any ‘sof’ modules from sof-firmware
Manjaro now has sof-firmware v1.5.1 mentioned in the blogpost.
I do not expect support for your hardware has been merged to this package yet, but it could start working soon in a future update, so I suggest trying to keep it installed

The previous discussion on archived Manjaro forum mentioned using a modprobe option to force loading of sof-hda-dsp driver - options snd-intel-dspcfg dsp_driver=3
but you have no modprobe options listed in ALSA data

(There is the other modprobe option to use the legacy snd_hda_intel driver - options snd-intel-dspcfg dsp_driver=1 but without the internal microphone)

the github package soundwire-dkms specific to this laptop has not been updated for 2 months
but there is a discussion on there about support for new kernel
Kernel 5.8.x compatibility by villuv · Pull Request #2 · maaarghk/soundwire-dkms · GitHub

Thanks for the links. I’m fairly sure I have sof-firmware 1.5.1 installed on the system. The modprobe options do not work for me, and the two commenters in the PR seem equally confused. I’m trying to see if I can set up bluetooth headphones, but that does require downgrading pulseaudio back to 13 for pulseaudio-bluetooth, and it’s too late for me to attempt this right now.

Small update. Bluetooth headphones work, but they hurt my ears so I would still like to get this working. No dice with headset, and trying to use an USB-C headphone jack with in-built audio card has it show up in alsamixer, but navigating to it quits back to terminal with message “cannot load mixer controls: broken pipe”. Speaker-test does not output any sound. All outputs are unmuted in alsamixer. The audio card is detected with aplay -l. The onboard audio chip is ALC711-CG and the jack audio chip is ALC4042.

Any further updates? Same laptop and same problem. Installed yesterday and have not been able to get audio to work yet. I have tried both of the grub modifications snd_hda_intel.dmic_detect=0
and
snd-intel-dspcfg.dsp_driver=1
and have also tried kernels 5.4.64-1, 5.8.6-1, and 5.9 experimental. sof-firmware drivers also installed to no effect. I am pretty new to linux so unfortunately it feels like I’m taking a bit of a shotgun approach here.

There is no solution for audio at the moment
but it is being worked on in opensuse
bugzilla.opensuse.org - Bug 1176200 - Audio does not work on Dell XPS 17 9700

Takashi Iwai
this requires the changes that will be included at first for 5.10 kernel

There is also an ongoing discussion on reddit
reddit.com/r/Dell - How to get fully working audio in Ubuntu 20.04 on XPS 9700
and the blog posted in OP
Dell XPS 2020 – How to get audio working on Linux – mark g’s blog

I suggest if you are new to Linux to watch those conversations for developments