Hardware acceleration incomplete

Hi Support, after my good experiences with getting help in another issue that worked I am now trying to get rid of another issue that cropped up over the time I get comfortable with my ‘new’ rig.

After the youtube hickup from a couple days ago I took a closer look at hardware accelerated video decode and ran into a snag. It seems that most of the codecs that are used for A/V get handled in software on the CPU instead of the logic in the GPU. I saw a post that talked about the need for a recompiled version of some packages because of patent law or something like that.

As as start I can provide the output of vdpauinfo :

display: :0   screen: 0
API version: 1
Information string: G3DVL VDPAU Driver Shared Library version 1.0

Video surface:

name   width height types
420    16384 16384  NV12 YV12 
422    16384 16384  UYVY YUYV 
444    16384 16384  Y8U8V8A8 V8U8Y8A8 
420_16 16384 16384  
422_16 16384 16384  
444_16 16384 16384  

Decoder capabilities:

name                        level macbs width height
MPEG1                          --- not supported ---
MPEG2_SIMPLE                    3 65536  4096  4096
MPEG2_MAIN                      3 65536  4096  4096
H264_BASELINE                  --- not supported ---
H264_MAIN                      --- not supported ---
H264_HIGH                      --- not supported ---
VC1_SIMPLE                     --- not supported ---
VC1_MAIN                       --- not supported ---
VC1_ADVANCED                   --- not supported ---
MPEG4_PART2_SP                  3 65536  4096  4096
MPEG4_PART2_ASP                 5 65536  4096  4096
DIVX4_QMOBILE                  --- not supported ---
DIVX4_MOBILE                   --- not supported ---
DIVX4_HOME_THEATER             --- not supported ---
DIVX4_HD_1080P                 --- not supported ---
DIVX5_QMOBILE                  --- not supported ---
DIVX5_MOBILE                   --- not supported ---
DIVX5_HOME_THEATER             --- not supported ---
DIVX5_HD_1080P                 --- not supported ---
H264_CONSTRAINED_BASELINE      --- not supported ---
H264_EXTENDED                  --- not supported ---
H264_PROGRESSIVE_HIGH          --- not supported ---
H264_CONSTRAINED_HIGH          --- not supported ---
H264_HIGH_444_PREDICTIVE       --- not supported ---
VP9_PROFILE_0                  --- not supported ---
VP9_PROFILE_1                  --- not supported ---
VP9_PROFILE_2                  --- not supported ---
VP9_PROFILE_3                  --- not supported ---
HEVC_MAIN                      --- not supported ---
HEVC_MAIN_10                   --- not supported ---
HEVC_MAIN_STILL                --- not supported ---
HEVC_MAIN_12                   --- not supported ---
HEVC_MAIN_444                  --- not supported ---
HEVC_MAIN_444_10               --- not supported ---
HEVC_MAIN_444_12               --- not supported ---
AV1_MAIN                       --- not supported ---
AV1_HIGH                       --- not supported ---
AV1_PROFESSIONAL               --- not supported ---

Output surface:

name              width height nat types
B8G8R8A8         16384 16384    y  NV12 YV12 UYVY YUYV Y8U8V8A8 V8U8Y8A8 P010 P016 A8I8 I8A8 
R8G8B8A8         16384 16384    y  NV12 YV12 UYVY YUYV Y8U8V8A8 V8U8Y8A8 P010 P016 A8I8 I8A8 
R10G10B10A2      16384 16384    y  NV12 YV12 UYVY YUYV Y8U8V8A8 V8U8Y8A8 P010 P016 A8I8 I8A8 
B10G10R10A2      16384 16384    y  NV12 YV12 UYVY YUYV Y8U8V8A8 V8U8Y8A8 P010 P016 A8I8 I8A8 

and vainfo :

Trying display: wayland
Trying display: x11
vainfo: VA-API version: 1.20 (libva 2.20.1)
vainfo: Driver version: Mesa Gallium driver 24.0.2-manjaro1.1 for AMD Radeon RX 6650 XT (radeonsi, navi23, LLVM 16.0.6, DRM 3.54, 6.6.19-1-MANJARO)
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileVP9Profile0            : VAEntrypointVLD
      VAProfileVP9Profile2            : VAEntrypointVLD
      VAProfileAV1Profile0            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc

Due to licensing problems, the official mesa packages disabled hardware acceleration for such codecs.

You could use nonfree.eu to reenable them. However, this requires you to change to the unstable branch of Manjaro.

See the whole thread here: https://forum.manjaro.org/t/unstable-manjaro-community-mesa-nonfree-codecs/135012

Seems the linked thread got either deleted over time or is otherwise restricted.

As it is not critical I keep this open for the meantime. As I prefer to stay on stable instead of breaking my system in the progress of enabling some hw accel and getting more “bleeding” egde packages with bugs not caught yet.

I stay open for other ideas.

No - don’t forget that an edge Manjaro system (unstable branch) is Arch stable - there is no hidden :bomb:

Bleeding edge is Artch Testing

I hate myself to saying this… buy nvidia is also a option :nauseated_face:

And i had a big issues with my nvidia card (last year) and flickering display for around 6month till the error was fixed by nvidia and required a workaround fix where my nvidia 2080Ti used 50 Watt in idle instead 10Watt for several month.

But since this licensing issue is there, im not sure if i would bought a AMD GPU Card in future.

Is there any light at the end of the tunnel? And how this problem are handled within the other distro’s?

Few month ago, there was a bug for the ext4 filesystem, affected was even the people like me with backported in LTS Kernel in stable branch… this bug introduced data corruption in the filesystem. :exploding_head:

Lucky i just had this cursed Kernel update for only 10 days on my system and didnt refreshed my backup in this time :cold_face:

I found the Info from this :bomb: again

This is just my personal solution.
according to your own decision and at your own risk.

AUR mesa-enable-h264

I have a custom repo for manjaro stable with mesa and couple packages i personally build and package:

Add to /etc/pacman.conf before [core]:

SigLevel = PackageRequired
Server = https://kloon15.github.io/manjaro-local/$arch

Add and sign the key: Signing Key

Reinstall the mesa packages, u might have to run it twice since it will complain about checksums not matching if u already have the official packages downloaded.

This might help you

I’m actually curious what licensing problems?
I heard before that they removed those because they weren’t free and I accepted that as just a dumb decision when I ran into the same issue months ago. But as far as I know every other distro I’m aware of supports those codecs so I’m curious why Manjaro would have a licensing issue with it.

This was discussed ad nauseam Upstream mesa removal of AVC/HEVC/VC-1 hardware acceleration (AMD GPUs) - #95 by philm

The gist is: nobody was sued yet, however if the codecs are included, you open up the possibility of a lawsuit at some point.

Then you are not well informed.

The very short legal version

Distributions backed by a company may be sued for intellectual property infringement if they are US based or their product is used in US.

Manjaro is backed by Manjaro Gmbh & Co, KG - although it is EU based - Manjaro is used everywhere.

  • Arch Linux is not backed by a company - no problem
  • EndeavourOS is not backed by a company - no problem
  • Fedora is backed by Red Hat - problem
  • OpenSuse is backed by Novell - problem
  • Red Hat is a company - problem
1 Like