Hard Drive is in Read-only

Im using Manjaro KDE and all of my hard drives besides my boot drive are stuck in read-only, Ive tried everything from creating new partition tables to formatting the drives but they are still stuck in read-only. Ive looked everywhere and I cant find a solution so I came here.

1 Like

Hi,
more information is needed - about your harddrives, the filesystem on them, your machine in general
and what you did and what happens vs what you expect to happen.
There is a thread here on “how to provide good information”.
You have to keep in mind that we can’t see what you can see …

all of my drives are in ext4, my cpu is a Ryzen 3 3300x, my gpu is rx480,

… that’s only about half of the expected answer - if even that.
see: how to provide good information

Good luck!

oh forget it Ill just live with it

If you devices are formatted using ext4 and you are only able to read them - then it is a permission problem. E.g. if you have been using it with another Linux then - even username is the same - the UID may be different.

If you format the device then the device will be owned by root both user and group and will be read-only.

Mount the device and use the terminal to set the permissions.

E.g. If your device mounts using Dolphin then open the device and open a terminal in the mounted folder. If it has a label it will usually mount in /run/media/$USER/label otherwise it will mount with the partition UUID e.g. /run/media/$USER/very-long-unique-identifier

In the terminal opened in the mounted folder - type the command below supply your password when asked or execute the command as root.

DISCLAIMER do not do this unless you are sure you are in the the folder /run/media/$USER/some-foldername

# chmod ugo+rw . -R

Edit - fixed the path - it always include the username :man_facepalming:

Ive fixed it, I changed the format from ext4 to ntfs and it fixed my problem

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.