Hard disk stops spinning after some time

So , i noticed that after the last update my hard disk stops spinning after a short period of inactivity , it never did that before
i have a few questions :
A) is spinning shutdown is bad ? should i disable it somehow(i have an old HDD)
B) if it’s bad , how to disable it
C) was this added deliberately in the update to minimize battery consumption ?

The manufacturers will tell you otherwise, but yes, spinning up and down is what wears out a hard disk the most. Spinning up drains a lot of current from your power supply and puts a lot of strain on the spindle motor, whereas it costs only a very small amount of power to keep the spindle at its operational speed.

In addition to that, depending on the manufacturer, many HDDs park their heads on the innermost cylinder of the platters. This means that during the disk’s startup and during shutdown, the heads will be in contact with the platters while they are still rotating ─ during normal operation, the heads float above the platters at a microscopic distance from the platter surface and are held there by aerodynamics.

The bottom line is that it is indeed best to keep the HDDs spinning, and especially so for older disks, where the spindle motor has already quite a bit of mileage on it and may experience more difficulty spinning up every time.

man hdparm

Pay close attention to the -B option. :wink:

Probably not, although a lot depends on what machine you have. If you have a laptop and you’re using tlp for power management, then this may be a new default setting in the tlp package, but if so, then this would have been an upstream decision, not a Manjaro decision.

Also keep in mind that the type of HDD plays a role in this. For instance, the Western Digital Green drives are set from the factory to spin down after only a few minutes. It saves you some money on electricity, which you can then spend on buying a new HDD because your Green drive has worn itself out by the time the warranty expires. :stuck_out_tongue:

1 Like

the issue was that spin value was hard-set in tlp config file


which was set to 128 on battery
i switched it back to 255 and now no spin downs
i don’t know how tlp was installed , if it was installed during the update , then im asking the devs to disable the spindown option , and yes it was going to hurt the hard disk if i didn’t notice (i did some research thanks to Aragorn)

1 Like

TLP is installed by default in most manjaro editions (and all of the official ones) I believe.

It is unlikely it as ‘added’… Though you can check your log, ex:

grep -i 'installed tlp' /var/log/pacman.log

It’s a Community package, so it shouldn’t come installed by default, although it did when I installed my system here ─ which isn’t even a laptop ─ now over two and a half years ago.

I have either way notified the maintainer to come and look at this thread. Perhaps he can explain the reasoning behind those settings, or decide to change them for future versions. That’s up to him. :wink:

I dont know why that would matter … there are a few things ‘community’ included by default.

But here is the shared packages-root profile that includes it:

shared/Packages-Root · master · Profiles & Settings / iso-profiles · GitLab

1 Like

From TLP documentation:

The APM setting for battery mode


corresponds to the Ubuntu default and should cause no problems.

From /etc/tlp.conf:

# Disk advanced power management level: 1..254, 255 (max saving, min, off).
# Levels 1..127 may spin down the disk; 255 allowable on most drives.
# Separate values for multiple disks with spaces. Use the special value 'keep'
# to keep the hardware default for the particular disk.
# Default: 254 (AC), 128 (BAT)

You’ll see that the hardware default for your disk is mostly likely already 128, so TLP really isn’t changing anything:

❯ sudo hdparm -I /dev/sda | grep "Advanced power management level"
	Advanced power management level: 128

The 255 value is not supported by some disk models and should never be a default setting.

i used 254 and still had the problem , used 255 the problem is gone
i removed tlp anyway , i don’t need it that much

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.