Had to revert to pulse after using pipewire for months. Recent update broke sound

I’ve switched to pipewire some months back and it worked fine, but the recent bigger update stopped any sound from working. I’ve reinstalled pipewire several times using the wiki and What is the correct way to install package “manjaro-pipewire”?

Had to go back to pulseaudio to get things working. Any ideas?

What branch are you using? get it with pacman-mirrors --get-branch
also always post your system info with inxi -Fxxxzam --no-host

I would recommend first to do this What is the correct way to install package “manjaro-pipewire”? - #22 by kI3RO and reboot
If you’ve no sound, maybe the config files are bad. Check /etc/pipewire/ for files with extension .pacnew and use them to replace manually your config, example:>

sudo mv /etc/pipewire/media-session.d/media-session.conf.pacnew /etc/pipewire/media-session.d/media-session.conf
sudo mv /etc/pipewire/media-session.d/alsa-monitor.conf.pacnew /etc/pipewire/media-session.d/alsa-monitor.conf
sudo mv /etc/pipewire/jack.conf.pacnew /etc/pipewire/jack.conf

if this doesn’t work, upgrade pipewire packages to unstable like this:

wget http://ftp.free.org/mirrors/repo.manjaro.org/repos/unstable/extra/x86_64/pipewire-1 0.3.25-1-x86_64.pkg.tar.zst
wget http://ftp.free.org/mirrors/repo.manjaro.org/repos/unstable/extra/x86_64/pipewire-alsa-1 0.3.25-1-x86_64.pkg.tar.zst
wget http://ftp.free.org/mirrors/repo.manjaro.org/repos/unstable/extra/x86_64/pipewire-jack-1 0.3.25-1-x86_64.pkg.tar.zst
wget http://ftp.free.org/mirrors/repo.manjaro.org/repos/unstable/extra/x86_64/pipewire-media-session-1 0.3.25-1-x86_64.pkg.tar.zst
wget http://ftp.free.org/mirrors/repo.manjaro.org/repos/unstable/extra/x86_64/pipewire-pulse-1 0.3.25-1-x86_64.pkg.tar.zst
sudo pacman -U *.zst

I’m currently on stable but I upgrade pipewire to latest for testing, so I manually download the packages from unstable.
PD: Also always select correct output in pavucontrol

Disclaimer: That’s normally not a good idea to mix packages from different branches as it can and will cause breakages.

The latest Pipewire and Bluez updates solved any issues I had, myself.

You also might want to nuke your ~/.config/pulse/ folder as some old settings might cause issues–especially if you use PulseEffects.

The config overwrite with .pacnew files solved my problem. Thanks!
Is there a way to restart audio system (reload config files) without reboot?

systemctl --user restart pipewire