Gwenview - not opening on double-click or right-click

Good Morning,
Ran into an interesting issue. When I try to open jpg files, Gwenview will try to open, then immediately close. I can open the images if I start Gwenview first and navigate to the directory.

I did confirm it was the default for jpg files

I also tried right-clicking on the file and opening it that way, but I get the same result. Wondering if anyone else is seeing this or has seen this behavior.

Edit: Now to add to the mystery. I got up and came back and now it works. All I did was leave Gwenview running for a few moments.

Try opening the file from the terminal. That way you will see what is going on. I’m guessing something is taking too long to process, delaying the opening.

That helped point it out. It was because I was using Cryptomator as an appimage and for whatever reason, it would stall out Dolphin. Swapped from AppImage to the AUR Bin. Thank you again for your assistance.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.