[GUIDE] How to set up Korean keyboard on Manjaro KDE

I’ve seen so many incomplete guides and know many people struggled with this (myself included!). This is the EASIEST guide out there on how to set up the Korean keyboard!

Difficulty: ★★☆☆☆

Step 1: Add ko_KR.UTF-8 UTF-8 to /etc/locale.gen :

echo ko_KR.UTF-8 UTF-8 | sudo tee -a /etc/locale.gen

Step 2: Update your system locale:

sudo locale-gen

Step 3: Update Manjaro so you can install software:

sudo pacman -Syyu

Step 4: Install your keyboard switcher, and the 한국어 fonts!

sudo pacman -S adobe-source-han-sans-kr-fonts fcitx5-hangul fcitx5-configtool  

Step 5: Open fcitx in your launcher
A keyboard icon (fcitx) will appear in your bottom right, near the clock

Step 6: Right click fcitx in your tray and select configure

Step 7: Deselect “Only Show Current Language”

Step 8: Find hangul, click it, then click the > button to send it to “Current Input Method”:

Step 9: Hit OK

Step 10: Type in Korean!!
By default, Ctrl + Space will swap you between Korean and English characters. You can also Right Click Fcitx again and select “Hangul” or “English” from “Input Method”.

Bonus tip: If you add fcitx to your Autostart in the settings, you can have Hangul start up every time you boot your computer.

I spent a while figuring out the exact steps you need for Hangul on fresh VMs, so hopefully this works for you!

If you have any problems, please reply to this thread or message me and I’ll do my best to help you. Also @Admins, if this thread is in the wrong spot, feel free to move it. Enjoy :smile: :smile: :smile:

5 Likes

I’m also planning on making a video guide that doesn’t use the terminal at all to do this. I’ll add it to this comment when I’m done!

I really like this bit:

and I’m going to add it to all my [HowTo]'s right now!

A post was split to a new topic: Question related to Korean keyboard guide

Hi! I recently installed Manjaro and tried setting up Korean keyboard according to this guide and some others (they ended up all being pretty similar), but I’m having trouble.
So I followed through step 5, and I could see the keyboard icon show up. But when I right click it and select configure, a popup saying “You’re currently running KDE, but KCModule for fcitx couldn’t be found, the package name of this KCModule is usually kcm-fcitx or kde-config-fcitx. Now it will open config file with default text editor.”, and then a Kate window pops up with text config file.
I tried getting kcm-fcitx once again but it didn’t make a difference.
Anyway, I found that I could get to that configure screen through searching for “input method” from the launcher, and I could execute step 7 through 9 alright. However Ctrl+Space doesn’t let me swap to Korean, even after rebooting.
Could you help me figure this out?

1 Like

Sorry for the late reply - You need slightly different packages than the post says.

You need to install fcitx5-hangul (instead of fcitx-hangul) and fcitx5-configtool (instead of kcm-fcitx). I can’t edit the OP since I don’t have an edit button for some reason.

That’s because you’re a basic user: if you don’t edit something for 15 days IIRC, it becomes immutable unless you’re a member.

I’ve edited it in for you…

:bowing_man: