Gufw not starting

I’ve recently noticed that gufw refuses to start - on my PC and laptop alike. It asks me to authenticate and nothing happens after that.
If I run it via “sudo gufw”, then after typing my password in I get the following:
“/usr/bin/gufw: line 2: [: =: unary operator expected”
(translated from Polish, so it might not be word for word).

I’m on stable Manjaro XFCE with all my packages up to date, including gufw and ufw. I’ve tried searching the Internet for an answer, but haven’t found any.
Does anyone know what’s wrong?

Welcome to the forum, why not searching directly here?

Huh, guess I should have searched the forums in addition to Google… Sorry for that and thanks for directing me!

Arch doesn’t seem to care much since it’s apparently due to sloppy upstream script:

@philm: Since you created an overlay, perhaps add the hacky fix in the solution above? I haven’t tried it myself, but others seem to be happy with it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.