Guest screen resolution on virt-manager

Hello everybody,
Is any tricks to make guest OS’s full screen /fitted to edges not like on screenshot below? there are empty black edges around sides.
Thanks and appreciated in advanced.

What bootloader are you using on your guest?
If using grub, you might want to play around a little bit to find an optimal resolution via kernel parameter as explained in the Setting via Grub section of KernelModesetting

Hope that helps.

1 Like

ok will try that.

I use grub yes. is other more proper than it is?

if i recall correctly, i used arandr and copied whatever command was there to the startup programs.
i think it was that solution(the last one):

but there are plenty of solutions proposed on multiple threads all over.

1 Like


You might want to try some other video settings. For Majaro VM’s I use the virtio model setting. No other options needed, screens are resizable by default with the option in view → scale display. If this does not work for you, then I do not know how to proceed.

Asking on the Kali forum would probably result in a better quality answer since this forum is for Manjaro. There probably is a guide of some sorts for running Kali in a VM. Edit: Something like this

1 Like

It’s same to on Windows 10 guest.

but i solved it upsetting display resolutions after login.