GTX 1070 Can't Get Vulkan to Work

Hello, I’ve been trying to figure this out for a while today. I can run games through Proton (I tried Guild Wars 2 anyways), but I can’t run things like vkcube or even vulkaninfo. Also performance seems very low in-game (30fps on low settings, it’s possible it’s bottle-necked by the CPU though…). Here’s everything I know / tried:

[nicl@nics-tornadof5 ~]$ lspci | grep 1070
01:00.0 VGA compatible controller: NVIDIA Corporation GP104BM [GeForce GTX 1070 Mobile] (rev a1)
[nicl@nics-tornadof5 ~]$ ls /usr/share/vulkan/icd.d/
[nicl@nics-tornadof5 ~]$ cat /usr/share/vulkan/icd.d/nvidia_icd.json 
    "file_format_version" : "1.0.0",
    "ICD": {
        "library_path": "",
        "api_version" : "1.2.133"
[nicl@nics-tornadof5 ~]$ glxinfo -B
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: nouveau (0x10de)
    Device: NV134 (0x1be1)
    Version: 20.1.8
    Accelerated: yes
    Video memory: 8173MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.3
    Max compat profile version: 4.3
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: nouveau
OpenGL renderer string: NV134
OpenGL core profile version string: 4.3 (Core Profile) Mesa 20.1.8
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.3 (Compatibility Profile) Mesa 20.1.8
OpenGL shading language version string: 4.30
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.1.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

So to me, that looks good, Vulkan should work. The NVIDIA drivers are installed, loaded, working, but …

[nicl@nics-tornadof5 ~]$ vkcube
Segmentation fault (core dumped)
[nicl@nics-tornadof5 ~]$ vulkaninfo 
ERROR at /build/vulkan-tools/src/Vulkan-Tools-1.2.153/vulkaninfo/vulkaninfo.h:247:vkEnumerateInstanceExtensionProperties failed with ERROR_INITIALIZATION_FAILED

I’m not sure how to proceed from here and would hugely appreciate support :slight_smile:.

Edit: Just so there’s no confusion, the packages vulkan-icd-loader and lib32-vulkan-icd-loader are installed.

Also the laptop is a Eurocom Tornado F5, pretty much everything is customizable so if a setting needs to be changed, I’ll change it!

You’re using the open source drivers. I highly recommend you switch to the Nvidia proprietary drivers.

AMD GPU’s work best on Open source, Nvidia works best on proprietary.

1 Like

Thank you, that solved the issue. I had both drivers installed. Now that it’s on the correct driver, the display scaling is wrong (everything is too large), it’s still on 1080p (but that’s the only listed option, unless I use NVIDIA’s tool, which is fine), but the display scaling is incorrect.

As a temporary fix, I’m forcing the font to 96 DPI, but I’m not sure why changing the driver has messed with the scaling so bad.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.