GTK3 save dialog jumps auto search preventing file naming

Recent updates changed default chromium based browsers (apparently nowhere else afaik) file save dialog, making it unusable, since every keystroke jumps automatically to search from the file name field.

This causes to type a non-existent folder into the field, so files are never saved, as described more or less here (link removed). That thread is marked “solved” since “its a GTK bug” but no solution was actually given. Moreover, it refers to XFCE desktop only, with a couple of proposed solutions from users.

Weird enough, kde users also heve reported the issue here’s an example (link removed), so it seems not be just a GTK issue.

In the AUR forum they mention a gtk-typeahead install to solve it maybe? but if i try to do that, it says it breaks libgtk-* compatibility.

So… is there a way to change/revert this (for Cinnamon or any other DE)? Right now its not only annoying but truly unusable, given that to type a single file name in that field we have to painfuly type-and-click at least 3 times for each character, since the cursor keeps jumping to the search field.

Thanks for any help :slight_smile:

----so i cannot insert images or links… :roll_eyes:

I am sure this is a GTK bug. I’m experiencing the same thing using telegram-desktop.

I have to type the full filename and extension manually in the GTK search box, then cut that text, then paste it to the filename field above before I can save it. Alternatively, bypassing the save dialog completely works – setting a default download location and saving directly by clicking save.

This bug as been reported at least twice in the Telegram git issues tracker and closed by the devs both times. They suggested trying the telegram linux binary from the official website which I was already using. But just to be sure I removed it and tried the one in the Manjaro repos and it did the same thing. So as far as the Telegram devs are concerned, this is not a Telegram bug.

In the git issues someone tried an older version of Telegram that used to work correctly but upon trying it on a freshly updated system even the old version repeated the same behaviour. I don’t recall what linux distro it was but it suggests to me that the GTK developers have broken something in the filesave dialog again and that there is nothing that can be done until they fix it and those changes propagate through to the official manjaro repos again.

If anyone else has a suggestion on how to workaround this issue please share it here because this bug is driving me crazy.


1 Like