GTK apps look blurry on wayland KDE

I’m running plasma 5.24.2 (currently the latest update from Manjaro). I wanted to try wayland but the gtk apps (firefox, thunderbird etc) look blurry when the fractional scaling is set at 125%. Is there any way to solve this?

1 Like

From arch wiki …
Might be related to this

Check in your /etc/environment or /home/.profile to have something like:

GDK_SCALE=2
GDK_DPI_SCALE=0.5

instead of the default

GDK_SCALE=1
GDK_DPI_SCALE=1
1 Like

The solution for Firefox and Thunderbird is even easier. You just have to ensure these are started in native Wayland mode. To do this, add

export MOZ_ENABLE_WAYLAND=1

to your ~/.profile file.

1 Like

Any way I can disable fractional scale in kde when I only need integer scale?

Is there any consensus on how to solve this for other apps? Firefox was easy enough to fix, but there are several other apps that still look pretty blurry for me.

1 Like

Not sure abouz any other solution, but after researching it a bit I think Plasma 5.26. should bring aid: This week in KDE: non-blurry XWayland apps! – Adventures in Linux and KDE
Though those settings can probably somehow already be applied manually(as mentioned above).