GRUB won't start


First of all: I know this has been posted often and there are multiple guides online, however, none of the things I tried worked. I also can’t post links or images so I’ll put them at the end.

The problem is that my laptop loads Ubuntu GRUB, skipping Manjaro GRUB which is higher in the boot order. When manually viewing bootable devices and trying to load Manjaro GRUB, the screen blinks black for a moment but nothing happens, same as when I try to load an empty USB stick, for example.

Booting from USB and using manjaro-chroot -a works

I tried this guide (1), the EFI System section until the yellow note, because I didn’t have a warning like that. I also tried this (2), didn’t work either. There were some other things I tried but I can’t find the links to the forum post. One of those contained a command like

cp /boot/efi/EFI/Manjaro/bootx64.efi /boot/efi/EFI/boot/grubx64.efi

or something similar (not sure with the paths), but that didn’t work either.

After trying the method from github (2), I think I have overwritten the windows bootloader or something, because my partition table looks like (3) but windows still loads fine (side question: Does that mean I can safely delete /dev/nvme0n1p6? That was meant to be the boot partition).

Thanks for any help!

(1): wiki.manjaro chroot
(2): gist.github

So I did some more digging, and it seems the problem was that I created a separate EFI partition, when I should’ve used the one Windows created on installation. Now it works