GRUB Unknown filesystem error after Windows 10 Installation

I downgraded from windows 11 to windows 10 recently and after I finished installation I tried going into manjaro. When I boot grub sends the message Unknown filesystem and goes into rescue mode.
During installation Windows created a recovery and a system additional partitions, I believe this changed the gpt location of the manjaro partition and therefore grub cant find the information to run but I don’t know how to fix this. Any help would be appreciated.
(I don’t know what additional information could be needed so feel free to ask for anything you consider necessary.)

windows probably messed up your grub… and there is the possibility of messed up UUIDS…
boot into manjaro live usb, chroot:
manjaro-chroot -a
reinstall grub for uefi:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

update it:
mkinitcpio -P && update-grub

then run these commands:
cat /etc/fstab
and check the uuids - the uuids in fstab should match the in the blkid

Have been busy recently. Just checked this. When I tried to run the grub-install
I get the error: failed to get canonical path of /boot/efi

That happens because you run it on the live session… read again pls.

Check if you have installed Won10 in BIOS mode either BIOS/GPT or BIOS/MBR.

The unknown filesystem is likley ntfs - which may happen in above scenario.

If it is the case there is no easy tip-toe to solve it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.