GRUB UI isnt display (just blank screen), but still work

It’s important to say - grub is working .
If I press enter on that blank screen, Ubuntu will open. If I press down+down+enter, then Windows will open up. Just no UI appears.
When Iam install Ubuntu, grub is working.

What I did try is:
_Set GRUB_GFXMODE=1920x1080 (640x480 isnt work neither)
_ grub-update

None of it is working.

1. I have to suggest to reread the things from arch-wiki

When GRUB is installed but the menu is not shown at boot

Check /etc/default/grub if GRUB_TIMEOUT is set to 0, in which case set it to a positive number: it sets the number of seconds before the default GRUB entry is loaded. Also check if GRUB_TIMEOUT_STYLE is set to hidden and set it to menu, so that the menu will be shown by default. Then regenerate the main configuration file and reboot to check if it worked.

2. I can share my own experience:

A few days ago i tried to change some things in my bios/UEFI and I think i did make a big mistake :scream:

  • Afterwards my PC did boot in “dark-mode”
  • There was no Logo from the bios any more
  • I could get into UEFI (with F2), but both screens stayed dark :frowning:
  • When rebooting
  • both monitors stayed dark
  • yet there was the beep from bios that it would start to boot
  • grub did not show up
  • after a while it seems the kernel did init the graphic-cards correct
  • lightdm showed up
  • i could work without problems
  • This stayed a few days until i got the courage to repair this

This time i did re-read my manual for the Mainboard three times. Then i did make a BIOS-Reset as it was shown in the manual.

Since then:

  • The Mainboard-Logo shows at boot
  • My BIOS/UEFI is accessible by F2 :sweat_smile:
  • Grub shows again :joy:
  • (And my PC boots a lot(!) faster :smiling_face_with_three_hearts: then before) :rofl:

In my case, I have to use GRUB_VIDEO_BACKEND=true, the UI will be suck, but it works.
Bcause my tablet has a touch screen, it has On Screen Keyboard integrated in the bios, some rare tweak from the manufacture, maybe that is why grub doesnt recognize graphic-card.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.