Grub throws an error saying 'symbol: grub_debug_malloc' not found

Hey. So I decided to put my laptop’s SSD in my PC (which only has Manjaro in it) and after booting to it, Grub fails and throws an error saying something about grub_debug_malloc not found. I heard that this happens when you try to boot from a BIOS system. I did install Manjaro on UEFI mode on my laptop and my PC has the Gigabyte EFI Hybrid Technology which does work when I put in an HDD that has UEFI Windows Installation on it. System Information on Windows also confirms this. Also, forgot to mention that before it used to work just fine. So, any idea why this could be happening?

@brahma Hey, so yeah, I wanted to put my SSD back to my PC and install the nvidia drivers properly this time without any tweaks and now this is happening lol. Mind help me out here? Thanks.

so what is the issue the grub or the nvidia?

It seems to be Grub cause I as soon as I put my SDD back in my PC, Grub failed.

the ssd was originally from your laptop and you want to put it now into a pc?

Yeah basically. Like I said, before I tried installing the nvidia drivers myself and messing up my entire system, it used to work.

i dont know about the grub malloc thing but if you saying its related to uefi, just change in your pc in bios to uefi mode and see if you can boot since your manjaro ssd is in uefi

The thing is, I don’t see any Boot options in my BIOS.

in your pc bios search for uefi and if its not set to only uefi set it
also secure boot disabled in pc bios
fast boot disabled too - you may not have this option
also AHCI enabled
google on how to do it - switching to uefi, disable secure boot - since im not having access to your bios
you may need to press ctrl+s for additional options in some bioses

SATA Controller is already set to AHCI.
I don’t have Secure boot option but I have Quick boot option which is disabled.
The only Boot option I can find is for CD/DVD which is set to EFI.
Ctrl + S doesn’t do anything.

are these 2 pic all of the options in your bios?maybe your bios is too old to have these options, if yes, you may be running in bios/legacy mode and manjaro is installed in uefi so it wont boot

It is quite old, this motherboard is from 2013. But then, how is that when I put my HDD that has UEFI Windows installed on it, it boots in UEFI mode with no problem?

Use the WIKI to restore GRUB to add working boot entry to the motherboard. Manjaro requires it on some motherboard, recent or old.

From live Manjaro USB, it should be simply:

# we chroot
manjaro-chroot -a

# we reinstal  GRUB efi
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

# we update GRUB

# we exit chroot to unmount the system

# we reboot

i dont know try what omana is suggesting, and when you are in live usb you can verify if you are actually running in bios or uefi with this command:
test -d /sys/firmware/efi && echo efi || echo bios

grub-install tell me ‘No EFI variables are supported on this system’.

It outputed bios.

You need to boot the USB as UEFI.

then you are running bios/legacy mode not uefi

I can’t, there’s no option that my BIOS prompts me and instead it automatically prefers Legacy over UEFI unless the ISO is strictly UEFI.