Grub suddenly disappeared

I have been using dual boot on Lenovo Slim 7 for a few months or so now without any issues in terms of booting up Windows or Manjaro Gnome.
Today I shut down my laptop from Manjaro as I wanted to boot into Windows.
When I powered it on it suddenly showed that it can’t find a bootable device or something like that. I restarted it and this time it booted straight into Windows as if there isn’t a linux partition on the drive.
I checked the BIOS settings but in the boot order only Windows boot manager is available there is no sign of the Grub manager or the linux partition.

Here is a very useful article on the wiki. GRUB/Restore the GRUB Bootloader - Manjaro

Windows has been doing this for years now.

1 Like

Looks like a Windows update updated the Win bootloader (which ignores Linux installs), you have to get Manjaro’s grub loader back in charge by re-installing it. Here’s how:

Boot from a Manjaro LiveUSB and open a terminal and type
manjaro-chroot -a
This lists installed systems, pick your Manjaro and log in. Assuming you have only one single drive called sda you can re-install grub with
sudo grub-install /dev/sda

Reboot and you should be back to normal.

1 Like

HI Jtyle6 and 6x12 and thank you for the replies and help.

unfortunately doing manjaro-chroot -a was showing ManajroLinux as an available system however it gave an error when i tried to sing into it,

I followed the steps in the article from Jtyle6 and despite not understanding quite what I was doing it appears to have worked. For root I just used the only path that was marked as ext4 and also mounted the efi, and just used the two EFI installation commands as is from the article page.

I find it weird that Windows caused this issue. I hadn’t booted into windows for some time and had previously successfully shut down and booted back into Manjaro multiple times. Is there a way to prevent this from happening when having a dual boot system?
Also with that being said I also have some issues with the Windows side of the machine where it fails to correctly install updates. I did some research on that as well after my linux died and from what I found it would seemed that the issue in the Windows system is that a system reserved partition doesn’t have enough free space ( which I have no idea how it is possible to happen since the PC comes with preinstalled windows and I would expect it to have sufficiently sized partitions). Do you think that the two issues may be connected? Windows having issues with system restricted partition size and it bugging the grub?

EDIT: I stand corrected actually I didn’t quite fix the issue. My PC now boots straight to manjaro without showing the grub manager. In the boot options in the BIOS I now have the possibility of choosing Manjaro in the boot order which is still a huge improvement from before. I have to see about bringing the Grub back.

I had this issue when I initially installed Manjaro a few days back. Manjaro is the only installed OS, but the PC would boot straight into Manjaro with no grub menu. This is the thread that solved the issue: Manjaro - Grub menu. Specifically the seventh post by banjo is what helped me. Changing GRUB_TIMEOUT_STYLE= from the default, hidden or quiet I think, to menu is what did the trick. Hope this helps.

1 Like

Assuming you have only one single drive called sda you can re-install grub with
sudo grub-install /dev/sda

Just do that from terminal inside manjaro.

Hang on, you said

“In the boot options in the BIOS I now have the possibility of choosing Manjaro in the boot order”

; does that mean windows and manjaro are on separate drives?

In that case (manjaro-sdb/win-sda) grub should be installed to where the win bootloader is, so on sda and not on sdb (where manjaro is installed). It must have been there before because otherwise the windows update couldn’t have wrecked it.

Maybe wait 'till someone can confirm.

1 Like

HI 6x12,
No I only have one SSD in the laptop and it was split between Win and Manjaro. When the grub died on me I checked the BIOS if I can boot into Manjaro from there by editing the boot order… However the only option to select Windows Boot Loader as a bootable option. After attempting the fix from the article given by Jtyle6 in the boot order in the BIOS I know also see Manjaro and I can set it to automatically boot into it. But there just isn’t a grub

Ok, in that case just boot up your installed Manjaro, open a terminal and reinstall grub with:
sudo grub-install /dev/sda

1 Like

I ran it but the grub menu still didn’t work. I did the fixes in the post from Christo524, and the grub menu is also back now, I guess maybe that was the problem, not very sure, but hope this post helps others that may have the same issues.
Thenks 6x12 for the help! :slight_smile:

Hi Christo524,
This fixed the missing the menu on boot. Although I had forgot to use the sudo update-grub and though it wasn’t working :D.
Thanks for sharing!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.