Grub: sparse file not allowed

Hello. After setting this values in /etc/default/grub:

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT="true"

I see that error when loading. I looked for many solutions, like this, but I want Grub to save the last entry, not using default. Is it possible on btrfs?

Oh, looks like only way around it is to have /boot mounted on a ext filesystem, if that’s true then it’s a pity

If you used grub-btrfs, but “save” does not work with many btrfs snapshots in Grub menu.


Very simple, you can change boot order, you do not need the Grub function “save”.

1 Like

I think you need to edit the grub like this to set the default boot entry. For 2nd option from grub main menu and 4th suboption from grub advanced menu, you should do like this

GRUB_DEFAULT="1>3"
GRUB_SAVEDEFAULT=false

see this post

https://unix.stackexchange.com/questions/62733/how-to-correctly-set-up-the-right-grub-2-default-menu-entry

Hope this helps

You will see the error when using grub and only on filesystems grub cannot write - e.g. btrfs or f2fs. That may change but until such change - that is how it is.

The only way around it is to create a separate /boot partiton and mount this before you mount the $esp.

I need it because if I launched Windows, I want to see Windows at restart and vice versa
It doesn’t matter, I can manually select every time. But saving was convenient

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.