"grub rescue" after win10 20H2 update

dear board,

after the 20H2 win10 update my manjaro bootloader only shows the “grub rescue>” terminal and says “error:unknown filesystem”.

in one single 500mb fat32 partition are three efi bootloaders for:
manjaro 21.0.5
mint 19.2
win10 20H2

luckily i can select at the “F12” bootdevice menu the mint bootloader (grub) and boot into mint.
i also tried to boot manjaro with mint’s grub but it only shows a black screen.
i updated mint grub but still the selected manjaro stays black.
i can mount manjaro in mint.
fsck does not show any errors.

test -d /sys/firmware/efi && echo efi || echo bios
and
inxi -Fxza ( check for UEFI only , not UEFI[legacy] or Bios )
confirm its “efi” and there is nothing with “gpt”

all three systems where running without problems an a new notebook since november.

i can see the bootloader’s in mint’s /boot/efi

they lock the same like the “/boot/efi” files in manjaro’s timeshift backups. same timestamps. they havent changed since months.

so. any idea what went wrong ? what i could try ?

thanks a lot for any advice !

Then start the USB stick or Mint.
Post blkid and fdisk -l.

Keruskerfuerst thanks for helping me:

somehow i am not able to include images !? → “Leider können Sie keine Medienelemente in einen Beitrag einbetten.”

/dev/nvme0n1p1 2048 1026047 1024000 500M EFI-System
/dev/nvme0n1p2 1026048 1058815 32768 16M Microsoft reserviert
/dev/nvme0n1p3 1058816 194862603 193803788 92,4G Microsoft Basisdaten
/dev/nvme0n1p4 194863104 196368383 1505280 735M Windows-Wiederherstellungsumgebung
/dev/nvme0n1p5 196370432 391684095 195313664 93,1G Linux-Dateisystem
/dev/nvme0n1p6 391684096 586997759 195313664 93,1G Linux-Dateisystem
/dev/nvme0n1p7 586997760 782311423 195313664 93,1G Linux-Dateisystem
/dev/nvme0n1p8 782311424 844810239 62498816 29,8G Linux Swap
/dev/nvme0n1p9 844810240 1885964287 1041154048 496,5G Linux-Dateisystem
/dev/nvme0n1p10 1885964288 3907028991 2021064704 963,7G Microsoft Basisdaten

I guess you need to reinstall Manjaro grub. Go to wiki.archlinux.org and follow chroot page instructions.

i just realized i can boot from mint’s grub into manjaro via initramfs fallback.
so is it save to reinstall grub from here or should i check other things first ?

1 Like

Chroot into Manjaro and reinstall Grub.

So you have booted into Manjaro? If so, then I guess it save to reinstall and update grub from there.

If you are able to boot in Manjaro then no need in chrooting, just do sudo grub-install --recheck

1 Like

Keruskerfuerst, megavolt, openminded thank you so much for helping me with this.

yes. i can boot manjaro but only with “manjaro fallback initramfs” not the standard selection.
so. could /should i fix this with “sudo mkinitcpio -p linux510” first before reinstalling grub ?

in “/boot/efi/” i see the manjaro, mint and win bootloaders. they look the same like in my rsync and timeshift. backups. is it actually possible to replace the files in the mounted “/boot/efi/” via “cp -a” or “rsync” with the ones in my backup’s ? or is this a really bad idea ?

sudo grub-install --recheck
is enough or better
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
like discribed in GRUB/Restore the GRUB Bootloader - Manjaro.
but of course without the “manjaro-chroot” as i am already in the targed system.

sorry i am new to that efi stuff and try not to make it worse :wink:

and i forgot to mension i had to add
GRUB_DISABLE_OS_PROBER=“false”
to “/etc/default/grub” few month ago to make win10 visibel after a manjaro update

That’s all you need to do.

yes. it worked.
openminded, Keruskerfuerst, megavolt thank you very much !!!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.