Grub: old warning is shown from uninstalled kernel version

Well hibernation options are often found in that grub config file.

The other paths are places kernels or their components might be found.

Did you actually check all those paths?

We can also double check installed packages

pacman -Qs 66

The error itself may be in dmesg. ex:

sudo dmesg | grep -i hiber

Apart from

…etc. - also:

cat /etc/fstab


sudo blkid

… I’m guessing an old entry is still present in your fstab file. :wink:

An fstab entry for a minor kernel version? :thinking:

(I cant think of how … but you kids with your timeshifts and btrfs maybe so :sweat_smile:)

Not sure about that to be honest but I have noticed that I got booted with the 6.7 series (twice) despite having set “savedefault” in GRUB … so it could be in issue, I suppose.

In any case, we’ll see when the OP posts the relevant output.

Regarding the grub config file:
Hibernation is activated with the “resume=UUID=[uuid of swap partition]” option.

As I said, everything seems to run perfectly so I don’t think that this is a real error. I think the problem is that an old error is still shown and I can’t seem to find anything on how to delete this message.
Or is it normal that an old kernel version is named in the error message, even if the problem still persists in newer versions?

I checked all those paths, I only have the kernels 6.6.26 (this kernel is used right now) und 6.6.25 installed, no leftovers.

sudo dmesg | grep -i hiber

One message is repeatedly shown, but not the message that I see during boot:

PM: hibernation: Registered nosave memory: [mem 0x00000000-0x00000fff]

Searching for this, it seems to be a “normal” message.


For the third time now.

Arguably the second time here, but I might be forgiven for not being sure, as the first was

With the comment making it less clear, would constitute leftovers because its multiple versions of 6.6, and on top of which we are continually avoiding any actual outputs and writing anecdotally.

Anyhoo. I dont know. Good luck.


Ok, thx for trying to help.
Mysterious problem…

I guess a bug in Grub might be possible.

the latter is no longer current - it can’t be installed anymore and will therefore potentially cause problems
(when dkms modules need to be built, for example)

IMO it should not even be there - the former should have replaced the latter.

Is it really that hard to transcribe what you see - it might give some people a clue.

I tried to read the message appearing more carefully now and it seems that the kernel version 6.6.19 is connected to an old hibernation image that could not be restored.

The message also says that the HibernateLocation EFI Variable is not matching.

So it seems the problem is something different, if no one has an easy solution at hand, I will try to find a solution and post it here, if I find something.

You cannot have kernel 6.6.26 and kernel 6.6.25 installed.
Not possible to my knowledge.
The files in /etc/mkinitcpio.d and in /boot literally have got the same name.
There could be the two versions in /lib/modules though

Yet you say that you do have both installed …

Good luck!

1 Like

This does not matter, I install custom kernels etc…
But I know enough about this, to see that there is no 6.6.19 entry.

The problem is what I described here: Grub: old warning is shown from uninstalled kernel version - #16 by gero45

There is an old hibernation image and that is what the warning is about.

I could not solve the message, but I deleted the swap partition and re-added it, so this image can no longer exist.
I am closing this, as my initial description was not really the actual problem.

What does not matter?
… that the file names are literally the same for both versions?

How can you confidently state that both
6.6.25 and 6.6.26
are installed?

Can you?

and how is that a solution?
It’s a reason to close the thread as “solved”.

so you say

“hibernation images” as you call them
are written to swap

swap is then - after reboot - used again

those “images” are not persistent

There cannot be such a thing as:

See this package for example: AUR (en) - linux-versioned-bin

You can install multiple kernel versions at the same time, I do this, to prevent unbootable systems etc.
But as I said, the kernel versions don’t matter here.

The message said, that an old hibernation image from 6.6.19 could not be restored.
I still don’t know what that is about, but as I removed the swap partition, the image should be gone now.
The only “problem” left is that this message still gets shown.

Without having seen that package:
you did not tell that you did this - if it works as intended on Manjaro as it may be working on Arch may be another issue

you did not mention that …

Did you use that?
Or is this just a theoretical example?

normally, this will not work - one would overwrite the other

and the hibernation image is still on swap

the moment that swap is used again to act as what it is intended to do
when a system is booted and running and using the swap
that image … is no longer there

I use a slightly modified version of this, for the linux-lts kernels, yes.
And it works, there are also many other users, so you don’t have to rely on me.

I actually don’t know what is correct; for clarification:
The message claims that an old hibernation image for 6.6.19 is still there and could not be restored because the Hibernation EFI variables (probably means the UUID of the swap partition) don’t match anymore.

So I would assume that the image is either maybe still stored, until it is used, or the image no longer exists (after first try, or third try or whatever), but the message is still shown.

I have now reformated the swap partition, so no data on that can exist anymore, but the message is still appearing.
I don’t know enough about this, but I assume that grub is somehow showing this, either because the old message simply got stuck (I don’t know whether this is possible) or because grub still has information stored somewhere about this hibernation image.

“image” is not stored anywhere but on swap
that is where data is written to when hibernating

if swap is used again - when the system is booted up and running - that image is … gone

As per the thread title, this was some warning (from somewhere).

A warning is just that -
is there an actual issue?

6.6.19 is even older than 6.6.25 and 6.6.26 what you where talking about here.

We have not seen it - only you have.
Where might that be from?

Is it “doing” or disrupting anything?
Or is it just a warning you see?

I hibernated again after some time, now the message is gone and hibernation is working like usual, so it seems that my reformating of the SWAP partition worked.

No there was no issue, I just found it annoying to see this message every time.

I think that it is from a failed attempt to use an hibernation image when the kernel was still 6.6.19.

Thx everyone.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.